aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVyacheslav Yurkov <uvv.mail@gmail.com>2021-10-04 22:21:31 +0200
committerArmin Kuster <akuster808@gmail.com>2021-10-08 17:23:52 -0700
commit5a1cc12c2f507aede95a6bf3a113856d7d17a025 (patch)
treec99f177c5df577c8aac932596bb894c5de7261b9
parent5578f481a3239b099494e5211fa6497899e9b4ff (diff)
downloadmeta-openembedded-contrib-5a1cc12c2f507aede95a6bf3a113856d7d17a025.tar.gz
grpc: fix cross-compilation of grpc applications
Backport a patch from grpc/master to be able to build c++ applications when gRPC_BUILD_GRPC_CPP_PLUGIN=OFF. The patch should be dropped on the recipe upgrade Signed-off-by: Vyacheslav Yurkov <uvv.mail@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 6696d7ef59bec46238aa610735480c1ce638cadf) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/grpc/grpc/0002-cmake-fix-cross-compilation-with-gRPC_BUILD_GRPC_CPP.patch55
-rw-r--r--meta-oe/recipes-devtools/grpc/grpc_1.38.1.bb1
2 files changed, 56 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/grpc/grpc/0002-cmake-fix-cross-compilation-with-gRPC_BUILD_GRPC_CPP.patch b/meta-oe/recipes-devtools/grpc/grpc/0002-cmake-fix-cross-compilation-with-gRPC_BUILD_GRPC_CPP.patch
new file mode 100644
index 0000000000..ce660f5cc1
--- /dev/null
+++ b/meta-oe/recipes-devtools/grpc/grpc/0002-cmake-fix-cross-compilation-with-gRPC_BUILD_GRPC_CPP.patch
@@ -0,0 +1,55 @@
+From 83a66aa45d63d79cbccc47a65998723a7d2d7637 Mon Sep 17 00:00:00 2001
+From: Thomas De Schampheleire <patrickdepinguin@gmail.com>
+Date: Wed, 23 Jun 2021 14:22:59 +0200
+Subject: [PATCH] cmake: fix cross-compilation with
+ gRPC_BUILD_GRPC_CPP_PLUGIN=OFF (#26292)
+
+* cmake: fix cross-compilation with gRPC_BUILD_GRPC_CPP_PLUGIN=OFF
+
+When cross-compiling gRPC, a _native_ version of 'grpc_cpp_plugin' is
+searched in the environment. For most use cases, a _cross_ version of this
+file is not needed and gRPC_BUILD_GRPC_CPP_PLUGIN can be set to OFF.
+
+However, when cross-building with -DgRPC_BUILD_GRPC_CPP_PLUGIN=OFF, there
+are some build errors, for example:
+
+make[3]: *** No rule to make target 'grpc_cpp_plugin', needed by 'gens/src/proto/grpc/reflection/v1alpha/reflection.grpc.pb.cc'. Stop.
+
+This is because there is still a hard dependency on 'grpc_cpp_plugin' for
+these targets, not taking into account the cross-compilation case.
+
+Fix by depending on the variable gRPC_CPP_PLUGIN, which is set correctly for
+either cross or native case.
+
+* regenerate projects
+---
+ CMakeLists.txt | 2 +-
+ templates/CMakeLists.txt.template | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index eeaf0b43c7..c60a64917a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -319,7 +319,7 @@ function(protobuf_generate_grpc_cpp)
+ --plugin=protoc-gen-grpc=${_gRPC_CPP_PLUGIN}
+ ${_protobuf_include_path}
+ ${REL_FIL}
+- DEPENDS ${ABS_FIL} ${_gRPC_PROTOBUF_PROTOC} grpc_cpp_plugin
++ DEPENDS ${ABS_FIL} ${_gRPC_PROTOBUF_PROTOC} ${_gRPC_CPP_PLUGIN}
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+ COMMENT "Running gRPC C++ protocol buffer compiler on ${FIL}"
+ VERBATIM)
+diff --git a/templates/CMakeLists.txt.template b/templates/CMakeLists.txt.template
+index cef2534cbd..f0afe5108e 100644
+--- a/templates/CMakeLists.txt.template
++++ b/templates/CMakeLists.txt.template
+@@ -389,7 +389,7 @@
+ --plugin=protoc-gen-grpc=<%text>${_gRPC_CPP_PLUGIN}</%text>
+ <%text>${_protobuf_include_path}</%text>
+ <%text>${REL_FIL}</%text>
+- DEPENDS <%text>${ABS_FIL}</%text> <%text>${_gRPC_PROTOBUF_PROTOC}</%text> grpc_cpp_plugin
++ DEPENDS <%text>${ABS_FIL}</%text> <%text>${_gRPC_PROTOBUF_PROTOC}</%text> <%text>${_gRPC_CPP_PLUGIN}</%text>
+ WORKING_DIRECTORY <%text>${CMAKE_CURRENT_SOURCE_DIR}</%text>
+ COMMENT "Running gRPC C++ protocol buffer compiler on <%text>${FIL}</%text>"
+ VERBATIM)
diff --git a/meta-oe/recipes-devtools/grpc/grpc_1.38.1.bb b/meta-oe/recipes-devtools/grpc/grpc_1.38.1.bb
index e2b86dad13..dfb44b819f 100644
--- a/meta-oe/recipes-devtools/grpc/grpc_1.38.1.bb
+++ b/meta-oe/recipes-devtools/grpc/grpc_1.38.1.bb
@@ -23,6 +23,7 @@ S = "${WORKDIR}/git"
SRCREV_grpc = "96b73272eadc01afb5fb45b92b408c47e4387274"
BRANCH = "v1.38.x"
SRC_URI = "git://github.com/grpc/grpc.git;protocol=https;name=grpc;branch=${BRANCH} \
+ file://0002-cmake-fix-cross-compilation-with-gRPC_BUILD_GRPC_CPP.patch \
"
# Fixes build with older compilers 4.8 especially on ubuntu 14.04
CXXFLAGS:append:class-native = " -Wl,--no-as-needed"