aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDomarys Correa <domarys.correa@ossystems.com.br>2020-05-18 12:00:30 -0300
committerKhem Raj <raj.khem@gmail.com>2020-05-19 17:14:09 -0700
commit3e431c3ce9bc58ff58a10c8fbd6ff556fcc66838 (patch)
tree187e32db52c58752536a0771970ab082c0333cb7
parentc68dad28f3287d91ed530991929cd896e83da41b (diff)
downloadmeta-openembedded-contrib-3e431c3ce9bc58ff58a10c8fbd6ff556fcc66838.tar.gz
python3-watchdog: Add recipe version 0.10.2
Signed-off-by: Domarys Correa <domarys.correa@ossystems.com.br> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-watchdog_0.10.2.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-watchdog_0.10.2.bb b/meta-python/recipes-devtools/python/python3-watchdog_0.10.2.bb
new file mode 100644
index 0000000000..93a1c192fe
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-watchdog_0.10.2.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Filesystem events monitoring"
+DEPENDS = "${PYTHON_PN}-argh"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI[sha256sum] = "c560efb643faed5ef28784b2245cf8874f939569717a4a12826a173ac644456b"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} = " \
+ ${PYTHON_PN}-argh \
+ ${PYTHON_PN}-pathtools3 \
+ ${PYTHON_PN}-pyyaml \
+ ${PYTHON_PN}-requests \
+"
+
+BBCLASSEXTEND = "native nativesdk"