aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-30 11:30:18 -0800
committerKhem Raj <raj.khem@gmail.com>2023-02-01 09:11:49 -0800
commit6cdb98eed2d68cb99361776e8e926703d385984c (patch)
treecb444930047bc52eb5177f9dc9dc7620eef01c8c
parent81b769d0981b5714b4d1787b36631f5279503b0d (diff)
downloadmeta-openembedded-contrib-6cdb98eed2d68cb99361776e8e926703d385984c.tar.gz
tesseract: Fix build with gcc13
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/tesseract/tesseract/0001-Fix-build-with-gcc-13-by-including-cstdint.patch32
-rw-r--r--meta-oe/recipes-graphics/tesseract/tesseract_5.3.0.bb2
2 files changed, 33 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/tesseract/tesseract/0001-Fix-build-with-gcc-13-by-including-cstdint.patch b/meta-oe/recipes-graphics/tesseract/tesseract/0001-Fix-build-with-gcc-13-by-including-cstdint.patch
new file mode 100644
index 0000000000..2978080c92
--- /dev/null
+++ b/meta-oe/recipes-graphics/tesseract/tesseract/0001-Fix-build-with-gcc-13-by-including-cstdint.patch
@@ -0,0 +1,32 @@
+From 2025b53de6b3d97285d7c5f80497493007c586c3 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 30 Jan 2023 11:27:07 -0800
+Subject: [PATCH] Fix build with gcc 13 by including <cstdint>
+
+gcc 13 moved some includes around and as a result <cstdint> is
+no longer transitively included [1]. Explicitly include it for
+int32_t.
+
+[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
+
+Upstream-Status: Submitted [https://github.com/tesseract-ocr/tesseract/pull/4009]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/ccutil/params.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/ccutil/params.h b/src/ccutil/params.h
+index f514d870..0f3f8743 100644
+--- a/src/ccutil/params.h
++++ b/src/ccutil/params.h
+@@ -21,6 +21,7 @@
+
+ #include <tesseract/export.h> // for TESS_API
+
++#include <cstdint>
+ #include <cstdio>
+ #include <cstring>
+ #include <string>
+--
+2.39.1
+
diff --git a/meta-oe/recipes-graphics/tesseract/tesseract_5.3.0.bb b/meta-oe/recipes-graphics/tesseract/tesseract_5.3.0.bb
index f791ad546b..057a7cd859 100644
--- a/meta-oe/recipes-graphics/tesseract/tesseract_5.3.0.bb
+++ b/meta-oe/recipes-graphics/tesseract/tesseract_5.3.0.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
SRCREV = "080da83cc51c4ef8b324a7e03146fe0bd7e0944b"
SRC_URI = "git://github.com/${BPN}-ocr/${BPN}.git;branch=main;protocol=https \
- "
+ file://0001-Fix-build-with-gcc-13-by-including-cstdint.patch"
S = "${WORKDIR}/git"