aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-04-09 08:18:37 -0700
committerArmin Kuster <akuster808@gmail.com>2018-04-13 12:43:48 -0700
commite32313fab9474ea4fdb4c3c5e3fba9b13f9a80ea (patch)
tree54e6aa72a800d91048f12b19a663121821abf74d
parentef3aae15b048d75e103a248223d6bd56a7db2822 (diff)
downloadmeta-openembedded-contrib-e32313fab9474ea4fdb4c3c5e3fba9b13f9a80ea.tar.gz
libreport: add PACKCONFIG for gtk
needed when no X11 in DISTRO_FEATURES [V2] fix typo in PACKAGECONFIG Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/libreport/libreport_2.9.2.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/libreport/libreport_2.9.2.bb b/meta-oe/recipes-extended/libreport/libreport_2.9.2.bb
index 525437bdb6..f2c661c8f7 100644
--- a/meta-oe/recipes-extended/libreport/libreport_2.9.2.bb
+++ b/meta-oe/recipes-extended/libreport/libreport_2.9.2.bb
@@ -5,7 +5,7 @@ HOMEPAGE = "https://abrt.readthedocs.org/"
LICENSE = "GPLv2+"
DEPENDS = "xmlrpc-c xmlrpc-c-native intltool-native \
json-c libtar libnewt libproxy rpm \
- augeas satyr systemd gtk+3 \
+ augeas satyr systemd \
"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
@@ -26,6 +26,9 @@ REQUIRED_DISTRO_FEATURES = "systemd"
inherit gettext autotools python3native pkgconfig
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES','x11','gtk','',d)}"
+PACKAGECONFIG[gtk] = "--with-gtk, --without-gtk, gtk+3,"
+
RDEPENDS_python3-libreport += "${PN}"
do_patch[prefuncs] += "do_gen_version"