aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-04-06 17:04:50 -0700
committerKhem Raj <raj.khem@gmail.com>2019-04-07 08:25:57 -0700
commit5ec597d83923f3c2f3643df56a6f80ee8ccdbf42 (patch)
treeedfacf651547c68088bef75dff1f233dae53345e
parent99a49e059fd82180f943d8cd6651b2c8e0d6289f (diff)
downloadmeta-openembedded-contrib-5ec597d83923f3c2f3643df56a6f80ee8ccdbf42.tar.gz
redis: Fix ocasional parallel build failure
Sometimes with high parallel build we see compile errors e.g. clang-8: error: linker command failed with exit code 1 (use -v to see invocation) make[3]: *** [Makefile:52: lua] Error 1 Therefore try to build dependencies before main build Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/redis/redis_4.0.12.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/redis/redis_4.0.12.bb b/meta-oe/recipes-extended/redis/redis_4.0.12.bb
index af99537f52..f09d226cc6 100644
--- a/meta-oe/recipes-extended/redis/redis_4.0.12.bb
+++ b/meta-oe/recipes-extended/redis/redis_4.0.12.bb
@@ -31,6 +31,10 @@ GROUPADD_PARAM_${PN} = "--system redis"
REDIS_ON_SYSTEMD = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}"
+do_compile_prepend() {
+ (cd deps && oe_runmake hiredis lua jemalloc linenoise)
+}
+
do_install() {
export PREFIX=${D}/${prefix}
oe_runmake install