aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2019-04-08 13:43:46 +0800
committerKhem Raj <raj.khem@gmail.com>2019-04-09 18:09:00 -0700
commit8099332416df1851a6aa5245ee91d507c7b35546 (patch)
tree045b1a744cff9b25b8448dc3ad942a56f002440b
parent71117c3cf299b40be41d9651aef740f524ce2efe (diff)
downloadmeta-openembedded-contrib-8099332416df1851a6aa5245ee91d507c7b35546.tar.gz
gd: fix compile error caused by -Werror=maybe-uninitialized
When enable DEBUG_BUILD, gd compile failed with error: | ../../git/src/gd_tiff.c:961:64: error: 'image_type' may be used uninitialized in this function [-Werror=maybe-uninitialized] | (image_type == GD_PALETTE || image_type == GD_INDEXED || image_type == GD_GRAY)) { | ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~ actually, this warning is misinformation, we can see the logic from: https://github.com/libgd/libgd/blob/master/src/gd_tiff.c image_type will be assigned no matter force_rgba is TRUE/FALSE. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/gd/gd_2.2.5.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gd/gd_2.2.5.bb b/meta-oe/recipes-support/gd/gd_2.2.5.bb
index 548d2c5788..426af2572e 100644
--- a/meta-oe/recipes-support/gd/gd_2.2.5.bb
+++ b/meta-oe/recipes-support/gd/gd_2.2.5.bb
@@ -35,6 +35,8 @@ EXTRA_OECONF += " --disable-rpath \
EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
+DEBUG_OPTIMIZATION_append = " -Wno-error=maybe-uninitialized"
+
do_install_append() {
# cleanup buildpaths from gdlib.pc
sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc