aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-31 09:16:38 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-31 09:52:38 -0700
commitb10cbda2867ff63f70357bb5e39c16391a22aede (patch)
tree642418876937a57f51721598cef9541a5f6557ba
parentf9300e78c42c0858c716d770775c7017bb6d820a (diff)
downloadmeta-openembedded-contrib-b10cbda2867ff63f70357bb5e39c16391a22aede.tar.gz
sharutils: Use update alternatives for uudecode/uuencode
This can then live with toybox Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/sharutils/sharutils_4.15.2.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/sharutils/sharutils_4.15.2.bb b/meta-oe/recipes-support/sharutils/sharutils_4.15.2.bb
index 48eb268939..8bbc6815ed 100644
--- a/meta-oe/recipes-support/sharutils/sharutils_4.15.2.bb
+++ b/meta-oe/recipes-support/sharutils/sharutils_4.15.2.bb
@@ -4,7 +4,7 @@ SECTION = "console/utils"
LICENSE="GPLv3+"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
-inherit gettext autotools
+inherit gettext autotools update-alternatives
SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
file://0001-Fix-build-with-clang.patch \
@@ -25,3 +25,7 @@ do_install_append() {
}
BBCLASSEXTEND = "native nativesdk"
+
+ALTERNATIVE_${PN} = "uudecode uuencode"
+ALTERNATIVE_LINK_NAME[uudecode] = "${bindir}/uudecode"
+ALTERNATIVE_LINK_NAME[uuencode] = "${bindir}/uuencode"