aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Kellermann <max.kellermann@gmail.com>2018-09-18 10:26:06 +0200
committerKhem Raj <raj.khem@gmail.com>2018-09-21 07:47:11 -0700
commitef734953ca7f77295a8804fc289355af5a92571e (patch)
tree2249507c5e242d7a2a936f8643b64bb4bccaede9
parent3fa64967e4b36379d5af44f70e8b8f25690288c7 (diff)
downloadmeta-openembedded-contrib-ef734953ca7f77295a8804fc289355af5a92571e.tar.gz
libmicrohttpd: add PACKAGECONFIG[https]
Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.59.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.59.bb b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.59.bb
index adbf831dd4..b44c66af7e 100644
--- a/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.59.bb
+++ b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.59.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=9331186f4f80db7da0e724bdd6554ee5"
SECTION = "net"
-DEPENDS = "libgcrypt gnutls file"
+DEPENDS = "file"
SRC_URI = "http://ftp.gnu.org/gnu/libmicrohttpd/${BPN}-${PV}.tar.gz"
SRC_URI[md5sum] = "8ab5123535549195aff19e91b4e49f48"
@@ -15,12 +15,13 @@ CFLAGS += "-pthread -D_REENTRANT"
EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../"
-PACKAGECONFIG ?= "curl"
+PACKAGECONFIG ?= "curl https"
PACKAGECONFIG_append_class-target = "\
${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \
"
PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
+PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls,"
do_compile_append() {
sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc