aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2017-09-05 14:12:51 -0500
committerMark Hatle <mark.hatle@windriver.com>2017-09-06 15:00:55 -0500
commita12d27e1f2667288aadf349bd98fb0149785b6aa (patch)
tree41aff8426c79d4ec714caec175492171162a4a96
parentc3fdfad9698749f26acb963f460a7599c78ad9f0 (diff)
downloadmeta-openembedded-contrib-a12d27e1f2667288aadf349bd98fb0149785b6aa.tar.gz
openlmi-tools: Only build if the necessary python pieces are available
Since this isn't a python library it doesn't really belong to meta-python. But I couldn't figure out where else to move it to. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
-rw-r--r--meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb b/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb
index b23869d767..13e67cba12 100644
--- a/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb
+++ b/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb
@@ -21,3 +21,8 @@ do_compile_prepend() {
do_install_prepend() {
cd cli
}
+
+python() {
+ if 'meta-python' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('Requires meta-python to be present.')
+}