aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2018-01-15 09:17:07 +0000
committerArmin Kuster <akuster808@gmail.com>2018-01-19 14:38:11 -0800
commit033a5b8af02d30499c4a641b490b6b3b8b9f39c8 (patch)
tree14969a3502f0bf8442f5a777072b1cd839e4ef7b
parentf521e20385371b07446f74a3043ff358507ad969 (diff)
downloadmeta-openembedded-contrib-033a5b8af02d30499c4a641b490b6b3b8b9f39c8.tar.gz
python-pyjks: add initial recipe for version 17.1.1
Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-pyjks.inc22
-rw-r--r--meta-python/recipes-devtools/python/python-pyjks_17.1.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pyjks_17.1.1.bb2
3 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyjks.inc b/meta-python/recipes-devtools/python/python-pyjks.inc
new file mode 100644
index 0000000000..d866c56504
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyjks.inc
@@ -0,0 +1,22 @@
+SUMMARY = "Pure-Python Java Keystore (JKS) library"
+DESCRIPTION = "PyJKS enables Python projects to load and manipulate\
+ Java KeyStore (JKS) data without a JVM dependency. PyJKS supports JKS,\
+ JCEKS, BKS and UBER (BouncyCastle) keystores."
+HOMEPAGE = "http://github.com/kurtbrose/pyjks"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9694d6cc724caf7f7386be88a4a81958"
+
+SRC_URI[md5sum] = "d53501e7c80d465969742bc6bee91d49"
+SRC_URI[sha256sum] = "709c44a303dd6b2464078ebeb677417e717818d4b3dc3844a462bef9d215dcc8"
+
+inherit pypi
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-javaobj-py3 \
+ ${PYTHON_PN}-pyasn1 \
+ ${PYTHON_PN}-pyasn1-modules \
+ ${PYTHON_PN}-pycryptodome \
+ ${PYTHON_PN}-twofish\
+"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pyjks_17.1.1.bb b/meta-python/recipes-devtools/python/python-pyjks_17.1.1.bb
new file mode 100644
index 0000000000..ce99f28350
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyjks_17.1.1.bb
@@ -0,0 +1,2 @@
+require python-pyjks.inc
+inherit setuptools
diff --git a/meta-python/recipes-devtools/python/python3-pyjks_17.1.1.bb b/meta-python/recipes-devtools/python/python3-pyjks_17.1.1.bb
new file mode 100644
index 0000000000..8982fcebc3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyjks_17.1.1.bb
@@ -0,0 +1,2 @@
+require python-pyjks.inc
+inherit setuptools3