aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2017-03-08 18:21:28 +0100
committerAndreas Oberritter <obi@opendreambox.org>2017-03-08 18:28:22 +0100
commit74590c783cbfbc70271823ad3364909201525b05 (patch)
tree9586476b913e82cdf680299d726426d00792433f
parent8877977e47a56132f389f1221b7c6bc51c113e77 (diff)
downloadmeta-openembedded-contrib-obi/krogoth-stable.tar.gz
meta-openembedded-contrib-obi/krogoth-stable.tar.bz2
meta-openembedded-contrib-obi/krogoth-stable.zip
kodi: Don't append to PACKAGECONFIG, fix disabling openglobi/krogoth-stable
It's hard to override from a distro config and the defaults are unsuitable for EGL platforms. Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb b/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb
index 46a316b40a..3925dda903 100644
--- a/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb
+++ b/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb
@@ -93,12 +93,12 @@ ACCEL ?= ""
ACCEL_x86 = "vaapi vdpau"
ACCEL_x86-64 = "vaapi vdpau"
-PACKAGECONFIG ??= "${ACCEL}"
-PACKAGECONFIG_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' x11', '', d)}"
-PACKAGECONFIG_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', ' opengl', ' openglesv2', d)}"
+PACKAGECONFIG ??= "${ACCEL} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl', 'openglesv2', d)}"
-PACKAGECONFIG[opengl] = "--enable-gl,--enable-gles,"
-PACKAGECONFIG[openglesv2] = "--enable-gles,--enable-gl,virtual/egl"
+PACKAGECONFIG[opengl] = "--enable-gl,--disable-gl,"
+PACKAGECONFIG[openglesv2] = "--enable-gles,--disable-gles,virtual/egl"
PACKAGECONFIG[vaapi] = "--enable-vaapi,--disable-vaapi,libva"
PACKAGECONFIG[vdpau] = "--enable-vdpau,--disable-vdpau,libvdpau"
PACKAGECONFIG[mysql] = "--enable-mysql,--disable-mysql,mysql5"