aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-08-15 16:02:19 -0400
committerAndreas Oberritter <obi@opendreambox.org>2017-02-16 11:29:16 +0100
commit0f062754cc394c366cbc13128947e7e9e5583547 (patch)
tree0845fd9bc291a4da067b44447583f32b110ba2d0
parent0a0d5e7adcd8f1aa5793d8c181c5ff774fdd9c53 (diff)
downloadmeta-openembedded-contrib-0f062754cc394c366cbc13128947e7e9e5583547.tar.gz
python-requests: update to version 2.11.0
* Bug fix release * Update RDEPENDS Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 0ebc75611c1ac04c3f03abf755db456a437b91c2) Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--meta-python/recipes-devtools/python/python-requests.inc4
-rw-r--r--meta-python/recipes-devtools/python/python-requests_2.11.0.bb (renamed from meta-python/recipes-devtools/python/python-requests_2.10.0.bb)0
-rw-r--r--meta-python/recipes-devtools/python/python3-requests_2.10.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-requests_2.11.0.bb5
4 files changed, 7 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python-requests.inc b/meta-python/recipes-devtools/python/python-requests.inc
index e00b25708e..7ce193c146 100644
--- a/meta-python/recipes-devtools/python/python-requests.inc
+++ b/meta-python/recipes-devtools/python/python-requests.inc
@@ -3,7 +3,7 @@ HOMEPAGE = "http://python-requests.org"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=d9bb3515869c0f426cb8441c899ae7f5"
-SRC_URI[md5sum] = "a36f7a64600f1bfec4d55ae021d232ae"
-SRC_URI[sha256sum] = "63f1815788157130cee16a933b2ee184038e975f0017306d723ac326b5525b54"
+SRC_URI[md5sum] = "147afc07d8967cf46359701551a6cb69"
+SRC_URI[sha256sum] = "b2ff053e93ef11ea08b0e596a1618487c4e4c5f1006d7a1706e3671c57dea385"
RDEPENDS_${PN} = "${PYTHON_PN}-email ${PYTHON_PN}-json ${PYTHON_PN}-netserver"
diff --git a/meta-python/recipes-devtools/python/python-requests_2.10.0.bb b/meta-python/recipes-devtools/python/python-requests_2.11.0.bb
index 627bc95d8a..627bc95d8a 100644
--- a/meta-python/recipes-devtools/python/python-requests_2.10.0.bb
+++ b/meta-python/recipes-devtools/python/python-requests_2.11.0.bb
diff --git a/meta-python/recipes-devtools/python/python3-requests_2.10.0.bb b/meta-python/recipes-devtools/python/python3-requests_2.10.0.bb
deleted file mode 100644
index e5220fac64..0000000000
--- a/meta-python/recipes-devtools/python/python3-requests_2.10.0.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-inherit pypi setuptools3
-require python-requests.inc
diff --git a/meta-python/recipes-devtools/python/python3-requests_2.11.0.bb b/meta-python/recipes-devtools/python/python3-requests_2.11.0.bb
new file mode 100644
index 0000000000..5e869b7883
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-requests_2.11.0.bb
@@ -0,0 +1,5 @@
+inherit pypi setuptools3
+require python-requests.inc
+
+# Add the runtime depends for selectors.py
+RDEPENDS_${PN} += "${PYTHON_PN}-misc"