aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Dechesne <nicolas.dechesne@linaro.org>2018-09-26 14:18:04 +0200
committerArmin Kuster <akuster808@gmail.com>2018-09-26 18:51:25 -0700
commit58a7d9e959905ecf0378401452e4b4e4786ba0e8 (patch)
treeade7d58f13b7e1c9fd85bc188639465fbd120a15
parentbf02ea81dc48bfe743ad242650c0b62e08bdfa2b (diff)
downloadmeta-openembedded-contrib-58a7d9e959905ecf0378401452e4b4e4786ba0e8.tar.gz
meta-openembedded-contrib-58a7d9e959905ecf0378401452e4b4e4786ba0e8.tar.bz2
meta-openembedded-contrib-58a7d9e959905ecf0378401452e4b4e4786ba0e8.zip
meta-multimedia: fixup LAYERDEPENDS
libebml depends on dos2unix classe since 26dafa0f3542 (libebml: inherit dos2unix), so LAYERDEPENDS needs to be updated accordingly, otherwise we are getting a ParseError: ERROR: ParseError at /srv/work/oe/meta-openembedded/meta-multimedia/recipes-mkv/libebml/libebml_1.3.0.bb:13: Could not inherit file classes/dos2unix.bbclass It was initially found with yocto-check-layer script. In OE/master branch, the dos2unix class was moved to oe-core, so the problem does not exist in master, and this patch is less invasive than cherry pick the change from master (move dos2unix from meta-oe to oe-core). Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-multimedia/conf/layer.conf2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-multimedia/conf/layer.conf b/meta-multimedia/conf/layer.conf
index cfedf2f6b6..a1dfed4e9b 100644
--- a/meta-multimedia/conf/layer.conf
+++ b/meta-multimedia/conf/layer.conf
@@ -27,6 +27,6 @@ BBFILE_PRIORITY_multimedia-layer = "6"
# cause compatibility issues with other layers
LAYERVERSION_multimedia-layer = "1"
-LAYERDEPENDS_multimedia-layer = "core"
+LAYERDEPENDS_multimedia-layer = "core openembedded-layer"
LAYERSERIES_COMPAT_multimedia-layer = "sumo"