aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-05-16 10:34:14 -0400
committerArmin Kuster <akuster808@gmail.com>2018-06-14 20:01:36 -0700
commitabd5934ea8a4c0d016e2f4b29770cbd406972436 (patch)
treef72d9034f597161272506440ecf71aaba5ee5fbf
parentf8a1c6888e814fc8320c6a9ef05e0bd883127b85 (diff)
downloadmeta-openembedded-contrib-abd5934ea8a4c0d016e2f4b29770cbd406972436.tar.gz
meta-openembedded-contrib-abd5934ea8a4c0d016e2f4b29770cbd406972436.tar.bz2
meta-openembedded-contrib-abd5934ea8a4c0d016e2f4b29770cbd406972436.zip
gnome-keyring: fix 'installed but not shipped' QA issue
Building the 'gnome-keyring' recipe with "installed-vs-shipped" included in ERROR_QA will result in: ERROR: gnome-keyring-3.20.0-r0 do_package: QA Issue: gnome-keyring: \ Files/directories were installed but not shipped in any package: /usr/lib64/pkcs11/gnome-keyring-pkcs11.la /lib64/security/pam_gnome_keyring.la >From various documents the .la files should not be packaged in either the main recipe package or the -dev package unless required. So inherit 'remove-libtool' to have all the .la files cleaned up as they don't appear to be necessary. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> (cherry picked from commit 973aec3a2ad1114ddf243bfef08e57847a85e142) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_3.20.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_3.20.0.bb b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_3.20.0.bb
index adf2ff9265..55640625d2 100644
--- a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_3.20.0.bb
+++ b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_3.20.0.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = " \
file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
"
-inherit distro_features_check gnomebase
+inherit distro_features_check gnomebase remove-libtool
DEPENDS = " \
intltool-native \