aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLei Maohui <leimaohui@cn.fujitsu.com>2018-08-17 18:19:53 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-19 16:09:28 -0700
commit7b500488115c67d657312135b48027a1c26e0955 (patch)
treef2ccf3189b769dabf7e5aa20b0aee1e92e1575e5
parentd4397bcc673e36f75fe9bd3c7b908e745c46a5b4 (diff)
downloadmeta-openembedded-contrib-7b500488115c67d657312135b48027a1c26e0955.tar.gz
postfix,esmtp: Fix confilct error in do_rootfs
Error: Transaction check error: file /usr/bin/mailq conflicts between attempted installs of esmtp-1.2-r0.x86_64 and postfix-3.2.2-r0.x86_64 file /usr/bin/newaliases conflicts between attempted installs of esmtp-1.2-r0.x86_64 and postfix-3.2.2-r0.x86_64 Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-daemons/postfix/postfix.inc7
-rw-r--r--meta-networking/recipes-support/esmtp/esmtp_1.2.bb6
2 files changed, 7 insertions, 6 deletions
diff --git a/meta-networking/recipes-daemons/postfix/postfix.inc b/meta-networking/recipes-daemons/postfix/postfix.inc
index f0d291792e..389136b52b 100644
--- a/meta-networking/recipes-daemons/postfix/postfix.inc
+++ b/meta-networking/recipes-daemons/postfix/postfix.inc
@@ -214,9 +214,10 @@ do_install_append_class-native() {
ln -sf ../sbin/sendmail.postfix ${D}${bindir}/mailq
}
-ALTERNATIVE_${PN} = "sendmail"
-ALTERNATIVE_TARGET[sendmail] = "${sbindir}/sendmail.postfix"
-ALTERNATIVE_LINK_NAME[sendmail] = "${sbindir}/sendmail"
+ALTERNATIVE_${PN} += "mailq newaliases"
+ALTERNATIVE_TARGET[mailq] = "${bindir}/mailq"
+ALTERNATIVE_TARGET[newaliases] = "${bindir}/newaliases"
+
ALTERNATIVE_PRIORITY = "120"
ALTERNATIVE_${PN}-doc += "mailq.1 newaliases.1 sendmail.1"
diff --git a/meta-networking/recipes-support/esmtp/esmtp_1.2.bb b/meta-networking/recipes-support/esmtp/esmtp_1.2.bb
index 2da73e7756..9fb817b498 100644
--- a/meta-networking/recipes-support/esmtp/esmtp_1.2.bb
+++ b/meta-networking/recipes-support/esmtp/esmtp_1.2.bb
@@ -18,10 +18,10 @@ EXTRA_OECONF = "--with-libesmtp=${STAGING_EXECPREFIXDIR}"
inherit autotools update-alternatives
-ALTERNATIVE_${PN} = "sendmail"
+ALTERNATIVE_${PN} += "mailq newaliases"
+ALTERNATIVE_TARGET[mailq] = "${bindir}/mailq"
+ALTERNATIVE_TARGET[newaliases] = "${bindir}/newaliases"
-ALTERNATIVE_LINK_NAME[sendmail] = "${sbindir}/sendmail"
-ALTERNATIVE_TARGET[sendmail] = "${bindir}/esmtp"
ALTERNATIVE_PRIORITY = "10"
ALTERNATIVE_${PN}-doc += "mailq.1 newaliases.1 sendmail.1"