aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-19 16:02:36 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-19 16:09:28 -0700
commitdc7d910b756f1f180c5b9c90d927a80ba44b4b9c (patch)
tree86688b9299198f384f829bab5a01c07ced66fe6b
parent8cec59341a845eb9776a54a5c34e6777f8a332aa (diff)
downloadmeta-openembedded-contrib-dc7d910b756f1f180c5b9c90d927a80ba44b4b9c.tar.gz
dlm: Fix build with glibc 2.28+
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-extended/dlm/dlm/0001-Include-sys-sysmacros.h-for-major-minor-macros-in-gl.patch41
-rw-r--r--meta-networking/recipes-extended/dlm/dlm_4.0.7.bb3
2 files changed, 43 insertions, 1 deletions
diff --git a/meta-networking/recipes-extended/dlm/dlm/0001-Include-sys-sysmacros.h-for-major-minor-macros-in-gl.patch b/meta-networking/recipes-extended/dlm/dlm/0001-Include-sys-sysmacros.h-for-major-minor-macros-in-gl.patch
new file mode 100644
index 0000000000..6f9a0a45a3
--- /dev/null
+++ b/meta-networking/recipes-extended/dlm/dlm/0001-Include-sys-sysmacros.h-for-major-minor-macros-in-gl.patch
@@ -0,0 +1,41 @@
+From a55ab8a07770296bf6a622df14f2f0445be16327 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 19 Aug 2018 15:58:49 -0700
+Subject: [PATCH] Include sys/sysmacros.h for major/minor macros in glibc 2.25+
+
+sys/sysmacros.h was included though sys/types.h until 2.28
+glibc release removed it therefore it must be included
+explicitly now.
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ dlm_controld/action.c | 2 ++
+ libdlm/libdlm.c | 1 +
+ 2 files changed, 3 insertions(+)
+
+diff --git a/dlm_controld/action.c b/dlm_controld/action.c
+index 84637f1..2b8ad6c 100644
+--- a/dlm_controld/action.c
++++ b/dlm_controld/action.c
+@@ -8,6 +8,8 @@
+
+ #include "dlm_daemon.h"
+
++#include <sys/sysmacros.h>
++
+ #include <corosync/corotypes.h>
+ #include <corosync/cmap.h>
+
+diff --git a/libdlm/libdlm.c b/libdlm/libdlm.c
+index a9e6195..499eb6a 100644
+--- a/libdlm/libdlm.c
++++ b/libdlm/libdlm.c
+@@ -14,6 +14,7 @@
+ #include <sys/ioctl.h>
+ #include <sys/param.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <stdint.h>
+ #include <stdlib.h>
+ #include <inttypes.h>
diff --git a/meta-networking/recipes-extended/dlm/dlm_4.0.7.bb b/meta-networking/recipes-extended/dlm/dlm_4.0.7.bb
index 18843a61f8..027864a1a7 100644
--- a/meta-networking/recipes-extended/dlm/dlm_4.0.7.bb
+++ b/meta-networking/recipes-extended/dlm/dlm_4.0.7.bb
@@ -9,7 +9,8 @@ SRC_URI = "https://releases.pagure.org/dlm/${BP}.tar.gz \
file://respect-ldflags-also-from-bin_ldflags.patch \
file://0001-dlm-fix-compile-error-since-xml2-config-should-not-b.patch \
file://0001-dlm-fix-package-qa-error.patch \
-"
+ file://0001-Include-sys-sysmacros.h-for-major-minor-macros-in-gl.patch \
+ "
SRC_URI[md5sum] = "aa604a10d5ac2d3414eb89ec6984cd12"
SRC_URI[sha256sum] = "639ddfc82369272a68d56816689736c00b8f1b6b2869a6b66b7dbf6dad86469a"