aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2019-09-14 15:46:41 +0200
committerKhem Raj <raj.khem@gmail.com>2019-09-14 07:16:38 -0700
commit19528ba2a6014ebe32b7a3d3099b037330228b88 (patch)
tree63cfa5600712ff0ef6eac4fb93d583b245e76d1d
parent62fc26075afc2d56a73777aad753a643fbdafbfa (diff)
downloadmeta-openembedded-contrib-19528ba2a6014ebe32b7a3d3099b037330228b88.tar.gz
evtest: update to 1.34
Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-test/evtest/evtest/add_missing_limits_h_include.patch37
-rw-r--r--meta-oe/recipes-test/evtest/evtest_1.34.bb (renamed from meta-oe/recipes-test/evtest/evtest_git.bb)7
2 files changed, 40 insertions, 4 deletions
diff --git a/meta-oe/recipes-test/evtest/evtest/add_missing_limits_h_include.patch b/meta-oe/recipes-test/evtest/evtest/add_missing_limits_h_include.patch
new file mode 100644
index 0000000000..b2bf94fd56
--- /dev/null
+++ b/meta-oe/recipes-test/evtest/evtest/add_missing_limits_h_include.patch
@@ -0,0 +1,37 @@
+From 5eb4ab1c139ea38ebe6bb4acba08b09ee7d77d3c Mon Sep 17 00:00:00 2001
+From: Baruch Siach <baruch@tkos.co.il>
+Date: Sun, 18 Aug 2019 10:01:06 +0300
+Subject: Add missing limits.h include
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Fixes build with musl libc that does not include limits.h indirectly via
+other headers.
+
+evtest.c: In function ‘scan_devices’:
+evtest.c:886:14: error: ‘PATH_MAX’ undeclared (first use in this function); did you mean INT8_MAX’?
+ char fname[PATH_MAX];
+ ^~~~~~~~
+
+Signed-off-by: Baruch Siach <baruch@tkos.co.il>
+Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
+---
+ evtest.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/evtest.c b/evtest.c
+index 37d4f85..548c203 100644
+--- a/evtest.c
++++ b/evtest.c
+@@ -56,6 +56,7 @@
+ #include <getopt.h>
+ #include <ctype.h>
+ #include <signal.h>
++#include <limits.h>
+ #include <sys/time.h>
+ #include <sys/types.h>
+ #include <unistd.h>
+--
+cgit v1.1
+
diff --git a/meta-oe/recipes-test/evtest/evtest_git.bb b/meta-oe/recipes-test/evtest/evtest_1.34.bb
index fa0d6e2fe5..3b6dc61408 100644
--- a/meta-oe/recipes-test/evtest/evtest_git.bb
+++ b/meta-oe/recipes-test/evtest/evtest_1.34.bb
@@ -7,10 +7,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
DEPENDS = "libxml2"
-SRCREV = "ab140a2dab1547f7deb5233be6d94a388cf08b26"
-SRC_URI = "git://anongit.freedesktop.org/evtest;protocol=git"
-
-PV = "1.33+${SRCPV}"
+SRCREV = "16e5104127a620686bdddc4a9ad62881134d6c69"
+SRC_URI = "git://anongit.freedesktop.org/evtest;protocol=git \
+ file://add_missing_limits_h_include.patch"
S = "${WORKDIR}/git"