aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-09-29 21:26:22 -0700
committerKhem Raj <raj.khem@gmail.com>2019-09-30 16:54:51 -0700
commit233d3b20c5892f34ce4949fcf9bb5d9bcde11d56 (patch)
tree6ada12679eb29e1f0cbb336a07b0f27ab9f062be
parent502ec72e60ecdd1bbcaeedefc228cdb9753f0f79 (diff)
downloadmeta-openembedded-contrib-233d3b20c5892f34ce4949fcf9bb5d9bcde11d56.tar.gz
fontforge: Upgrade to 20190801 release
License-Update: Dropped plugins [1] and gnulib [2] - Add a fix for musl build to include sys/select.h - gnulib dependency is not needed anymore - Disable libuninameslist, recipe is missing in OE [1] https://github.com/fontforge/fontforge/commit/ed62345e3ad7484cd0bf714f5ef9c7012dad157c#diff-9879d6db96fd29134fc802214163b95a [2] https://github.com/fontforge/fontforge/commit/51c045a09804c20725527878c753df6ba96dafa8#diff-9879d6db96fd29134fc802214163b95a Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/fontforge/fontforge/0001-include-sys-select-on-non-glibc-platforms.patch29
-rw-r--r--meta-oe/recipes-graphics/fontforge/fontforge_20190413.bb62
-rw-r--r--meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb46
3 files changed, 75 insertions, 62 deletions
diff --git a/meta-oe/recipes-graphics/fontforge/fontforge/0001-include-sys-select-on-non-glibc-platforms.patch b/meta-oe/recipes-graphics/fontforge/fontforge/0001-include-sys-select-on-non-glibc-platforms.patch
new file mode 100644
index 0000000000..54ff7b76d2
--- /dev/null
+++ b/meta-oe/recipes-graphics/fontforge/fontforge/0001-include-sys-select-on-non-glibc-platforms.patch
@@ -0,0 +1,29 @@
+From 798f2816130838f3618212291de6ab0ea814c868 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 29 Sep 2019 20:39:02 -0700
+Subject: [PATCH] include sys/select on non-glibc platforms
+
+musl needs sys/select.h for defining fd_set
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ gdraw/gdraw.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gdraw/gdraw.c b/gdraw/gdraw.c
+index 24591b778..217c63140 100644
+--- a/gdraw/gdraw.c
++++ b/gdraw/gdraw.c
+@@ -32,7 +32,7 @@
+ #include "gkeysym.h"
+ #include "ustring.h"
+
+-#if __Mac || __FreeBSD__ || __NetBSD__ || __OpenBSD__ || __DragonFly__
++#if __Mac || __FreeBSD__ || __NetBSD__ || __OpenBSD__ || __DragonFly__ || !defined(__GLIBC__)
+ # include <sys/select.h>
+ #endif
+
+--
+2.23.0
+
diff --git a/meta-oe/recipes-graphics/fontforge/fontforge_20190413.bb b/meta-oe/recipes-graphics/fontforge/fontforge_20190413.bb
deleted file mode 100644
index ee3bc58bc4..0000000000
--- a/meta-oe/recipes-graphics/fontforge/fontforge_20190413.bb
+++ /dev/null
@@ -1,62 +0,0 @@
-SUMMARY = "A font editor"
-HOMEPAGE = "http://fontforge.github.io/en-US/"
-LICENSE = "BSD-3-Clause & GPLv3"
-LIC_FILES_CHKSUM = " \
- file://COPYING.gplv3;md5=d32239bcb673463ab874e80d47fae504 \
- file://LICENSE;md5=5f9637af5c51f2e8d06385ef38eb48f1 \
-"
-
-DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg python libtool uthash gnulib gettext-native"
-DEPENDS_append_class-target = " libxi"
-
-inherit autotools pkgconfig pythonnative distro_features_check gettext gtk-icon-cache mime
-
-REQUIRED_DISTRO_FEATURES_append_class-target = " x11"
-
-SRC_URI = "git://github.com/${BPN}/${BPN}.git"
-# tag 20190413
-SRCREV = "7f6f1d021fdfea7789972f9534ba3241616d8dfc"
-S = "${WORKDIR}/git"
-
-EXTRA_OECONF_append_class-native = " with_x=no"
-
-do_configure_prepend() {
- # uthash sources are expected in uthash/src
- currdir=`pwd`
- cd ${S}
-
- mkdir -p uthash/src
- cp ${STAGING_INCDIR}/ut*.h uthash/src
-
- # avoid bootstrap cloning gnulib on every configure
- cat >.gitmodules <<EOF
-[submodule "gnulib"]
- path = gnulib
- url = git://git.sv.gnu.org/gnulib
-EOF
- cp -rf ${STAGING_DATADIR}/gnulib ${S}
-
- # --force to avoid errors on reconfigure e.g if recipes changed we depend on
- # | bootstrap: running: libtoolize --quiet
- # | libtoolize: error: 'libltdl/COPYING.LIB' exists: use '--force' to overwrite
- # | ...
- ./bootstrap --force
-
- cd $currdir
-}
-
-PACKAGES =+ "${PN}-python"
-
-RPROVIDES_${PN}-dbg += "${PN}-python-dbg"
-
-FILES_${PN} += " \
- ${datadir}/appdata \
- ${datadir}/metainfo \
- ${datadir}/mime \
-"
-
-FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR} ${datadir}/${BPN}/python"
-RDEPENDS_${PN}-python = "python"
-
-# for e.g kde's oxygen-fonts
-BBCLASSEXTEND = "native"
diff --git a/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb b/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
new file mode 100644
index 0000000000..25c2ce81f8
--- /dev/null
+++ b/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
@@ -0,0 +1,46 @@
+SUMMARY = "A font editor"
+HOMEPAGE = "http://fontforge.github.io/en-US/"
+LICENSE = "BSD-3-Clause & GPLv3"
+LIC_FILES_CHKSUM = " \
+ file://COPYING.gplv3;md5=d32239bcb673463ab874e80d47fae504 \
+ file://LICENSE;md5=d042f3d2a8fd7208b704a499168e3c89 \
+"
+
+DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg python libtool uthash gettext-native"
+DEPENDS_append_class-target = " libxi"
+
+inherit autotools pkgconfig pythonnative distro_features_check gettext gtk-icon-cache mime
+
+REQUIRED_DISTRO_FEATURES_append_class-target = " x11"
+
+# tag 20190801
+SRCREV = "ac635b818e38ddb8e7e2e1057330a32b4e25476e"
+SRC_URI = "git://github.com/${BPN}/${BPN}.git \
+ file://0001-include-sys-select-on-non-glibc-platforms.patch \
+"
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF += "--without-libuninameslist"
+EXTRA_OECONF_append_class-native = " with_x=no"
+
+#do_configure_prepend() {
+# uthash sources are expected in uthash/src
+# mkdir -p ${S}/uthash/src
+# cp ${STAGING_INCDIR}/ut*.h ${S}/uthash/src
+#}
+
+PACKAGES =+ "${PN}-python"
+
+RPROVIDES_${PN}-dbg += "${PN}-python-dbg"
+
+FILES_${PN} += " \
+ ${datadir}/appdata \
+ ${datadir}/metainfo \
+ ${datadir}/mime \
+"
+
+FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR} ${datadir}/${BPN}/python"
+RDEPENDS_${PN}-python = "python"
+
+# for e.g kde's oxygen-fonts
+BBCLASSEXTEND = "native"