aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2018-11-05 00:59:15 -0500
committerKhem Raj <raj.khem@gmail.com>2018-11-09 07:29:59 -0800
commit0e0104d62227f3dc361529d8edf035325bba5767 (patch)
tree8f1fb994d20adac751e200530fc551779bb6846a
parent97f56b745096a9cc3156b38f190d8aca6f56ce37 (diff)
downloadmeta-openembedded-contrib-0e0104d62227f3dc361529d8edf035325bba5767.tar.gz
libunique: fix installed-vs-shipped qa issue
libunique shows installed-vs-shipped QA issue if configure option '--disable-introspection' is set by: 1) in gobject-introspection*.bbclass that the 'qemu-usermode' is not supported by bsp and then not set in MACHINE_FEATURES or: 2) set in local.conf directly: EXTRA_OECONF_append_pn-libunique = " --disable-introspection" Remove empty directory to fix the QA issue. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-xfce/recipes-extended/libunique/libunique_1.1.6.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-xfce/recipes-extended/libunique/libunique_1.1.6.bb b/meta-xfce/recipes-extended/libunique/libunique_1.1.6.bb
index 49ed07ad97..a6475cef6d 100644
--- a/meta-xfce/recipes-extended/libunique/libunique_1.1.6.bb
+++ b/meta-xfce/recipes-extended/libunique/libunique_1.1.6.bb
@@ -28,3 +28,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
inherit autotools pkgconfig gobject-introspection distro_features_check gtk-doc
REQUIRED_DISTRO_FEATURES = "x11"
+
+do_install_append () {
+ rmdir --ignore-fail-on-non-empty ${D}${datadir}
+}