aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2015-02-10 14:55:10 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-12 19:35:40 +0100
commit618c70da1e9b7062196dfaf7be28e63402b81d9d (patch)
tree790108693b3f75b914295cce748475c4a38a1cf7
parent81508befadbd7c2c2f0079b0db35333692bd77ee (diff)
downloadmeta-openembedded-contrib-618c70da1e9b7062196dfaf7be28e63402b81d9d.tar.gz
python-pip: add python-distribute in RDEPENDS
Fix the following runtime issue of pip: # pip Traceback (most recent call last): File "/usr/bin/pip", line 5, in <module> from pkg_resources import load_entry_point ImportError: No module named pkg_resources Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
-rw-r--r--meta-python/recipes-devtools/python/python-pip_1.5.6.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-pip_1.5.6.bb b/meta-python/recipes-devtools/python/python-pip_1.5.6.bb
index 0c240e4607..b4ce9e5f3c 100644
--- a/meta-python/recipes-devtools/python/python-pip_1.5.6.bb
+++ b/meta-python/recipes-devtools/python/python-pip_1.5.6.bb
@@ -12,4 +12,4 @@ S = "${WORKDIR}/pip-${PV}"
inherit setuptools
# Since PIP is like CPAN for PERL we need to drag in all python modules to ensure everything works
-RDEPENDS_${PN} = "python-modules"
+RDEPENDS_${PN} = "python-modules python-distribute"