aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-12-11 18:09:52 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-12-17 12:56:21 +0100
commit27a660fa7e9045d33bfba41bc5d58ecd159b33e0 (patch)
treef01c8cd8776be46b5879bed91fe8ece3925fe3cb
parentd2e228d754e362f42c3da6e042a407e6cb761a50 (diff)
downloadmeta-openembedded-contrib-27a660fa7e9045d33bfba41bc5d58ecd159b33e0.tar.gz
meta-openembedded-contrib-27a660fa7e9045d33bfba41bc5d58ecd159b33e0.tar.bz2
meta-openembedded-contrib-27a660fa7e9045d33bfba41bc5d58ecd159b33e0.zip
polkit-gnome, gdm, network-manager-applet: blacklist because polkit-gnome.do_configure fails
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_0.9.8.10.bb2
-rw-r--r--meta-gnome/recipes-gnome/gdm/gdm_2.32.2.bb2
-rw-r--r--meta-oe/recipes-extended/polkit/polkit-gnome_0.102.bb2
3 files changed, 6 insertions, 0 deletions
diff --git a/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_0.9.8.10.bb b/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_0.9.8.10.bb
index 663c38cbe2..8c271edf4e 100644
--- a/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_0.9.8.10.bb
+++ b/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_0.9.8.10.bb
@@ -8,6 +8,8 @@ inherit gnomebase gtk-icon-cache
GNOME_COMPRESS_TYPE = "xz"
+PNBLACKLIST[network-manager-applet] ?= "Depends on broken polkit-gnome"
+
SRC_URI += " \
file://0001-remove-classes-and-properties-which-are-not-supporte.patch \
file://0002-Add-support-for-AP-mode-setting-for-wifi-sharing.patch \
diff --git a/meta-gnome/recipes-gnome/gdm/gdm_2.32.2.bb b/meta-gnome/recipes-gnome/gdm/gdm_2.32.2.bb
index d8f015064a..b2ae9ac073 100644
--- a/meta-gnome/recipes-gnome/gdm/gdm_2.32.2.bb
+++ b/meta-gnome/recipes-gnome/gdm/gdm_2.32.2.bb
@@ -6,6 +6,8 @@ DEPENDS = "xinput gnome-panel tcp-wrappers libcanberra libxklavier grep consolek
PR = "r18"
+PNBLACKLIST[gdm] ?= "Depends on broken polkit-gnome"
+
inherit gnome update-rc.d systemd useradd
SRC_URI += " \
diff --git a/meta-oe/recipes-extended/polkit/polkit-gnome_0.102.bb b/meta-oe/recipes-extended/polkit/polkit-gnome_0.102.bb
index b262b5ef8f..f5480e780f 100644
--- a/meta-oe/recipes-extended/polkit/polkit-gnome_0.102.bb
+++ b/meta-oe/recipes-extended/polkit/polkit-gnome_0.102.bb
@@ -10,6 +10,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=74579fab173e4c5e12aac0cd83ee98ec \
SRC_URI = "http://hal.freedesktop.org/releases/polkit-gnome-${PV}.tar.bz2 \
"
+PNBLACKLIST[polkit-gnome] ?= "Fails to build, m4:configure.ac:125: recursion limit of 1024 exceeded, use -L<N> to change it"
+
PR = "r2"
EXTRA_OECONF = "\