aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2019-07-11 13:52:57 +0800
committerKhem Raj <raj.khem@gmail.com>2019-07-11 14:01:28 -0700
commit41f6815e0865b6d1c187a07806dc1f02e40ef45c (patch)
tree080c5b1f71906194adde99d3fcab743a2e38f774
parent29ad635bdd92574a22ded724be96e8882dd37c6b (diff)
downloadmeta-openembedded-contrib-41f6815e0865b6d1c187a07806dc1f02e40ef45c.tar.gz
satyr: fix "Nothing RPROVIDES" when multilib enabled
Multilib enabled, and add IMAGE_INSTALL_append = " python3-satyr" in local.conf fix below problem: ERROR: Required build target 'lib32-core-image-minimal' has no buildable providers. Missing or unbuildable dependency chain was: ['lib32-core-image-minimal', 'lib32-python3-satyr'] Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/satyr/satyr_0.27.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/satyr/satyr_0.27.bb b/meta-oe/recipes-support/satyr/satyr_0.27.bb
index 10dfc2bade..cc07dcb06e 100644
--- a/meta-oe/recipes-support/satyr/satyr_0.27.bb
+++ b/meta-oe/recipes-support/satyr/satyr_0.27.bb
@@ -19,8 +19,8 @@ DEPENDS += " \
gdb \
"
-PACKAGES += "python3-${PN}"
-FILES_python3-${PN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}"
+PACKAGES += "python3-${BPN}"
+FILES_python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}"
PACKAGECONFIG ??= "python3 rpm"
PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2"