aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@nextrem.ch>2017-01-30 09:01:59 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-13 18:43:25 +0100
commit63bdd4f51c46c18e6579d2b9f3d373c65238e306 (patch)
tree4289d8c732c63f9aeb853255ebaaf25998fa6fc3
parentb4acda8e38b05d7f0c847b4e8e2755fe7235df28 (diff)
downloadmeta-openembedded-contrib-63bdd4f51c46c18e6579d2b9f3d373c65238e306.tar.gz
python3-multidict: make repeated builds work even without sphinx
Make clean was implicitly calling sphinx which lead to errors. Signed-off-by: Pascal Bach <pascal.bach@nextrem.ch> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-multidict/0001-Allow-calling-make-clean-without-sphinx-build.patch34
-rw-r--r--meta-python/recipes-devtools/python/python3-multidict_2.1.4.bb2
2 files changed, 36 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-multidict/0001-Allow-calling-make-clean-without-sphinx-build.patch b/meta-python/recipes-devtools/python/python3-multidict/0001-Allow-calling-make-clean-without-sphinx-build.patch
new file mode 100644
index 0000000000..d1d7ef5756
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-multidict/0001-Allow-calling-make-clean-without-sphinx-build.patch
@@ -0,0 +1,34 @@
+From 39e13b4e3f7a1d1dd748e80cee241d511865d4e8 Mon Sep 17 00:00:00 2001
+From: Pascal Bach <pascal.bach@nextrem.ch>
+Date: Mon, 16 Jan 2017 21:29:12 +0100
+Subject: [PATCH] Allow calling make clean without sphinx-build
+
+Currently make clean fails without sphinx-build installed
+However sphinx-build is not really necessary to do a clean.
+This trick makes the docs/Makefile use the false binary instead of
+sphinx-build for the check when a clean is done.
+
+Upstream-Status: Submitted https://github.com/aio-libs/multidict/pull/41
+
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 8f525f3..6d601e5 100644
+--- a/Makefile
++++ b/Makefile
+@@ -51,8 +51,8 @@ clean:
+ rm -rf coverage
+ rm -rf build
+ rm -rf cover
+- make -C docs clean
+- python setup.py clean
++ make -C docs clean SPHINXBUILD=false
++ python3 setup.py clean
+ rm -f multidict/_multidict.html
+ rm -f multidict/_multidict.c
+ rm -f multidict/_multidict.*.so
+--
+2.7.4
+
diff --git a/meta-python/recipes-devtools/python/python3-multidict_2.1.4.bb b/meta-python/recipes-devtools/python/python3-multidict_2.1.4.bb
index 4a36a3d4d7..62895d2b37 100644
--- a/meta-python/recipes-devtools/python/python3-multidict_2.1.4.bb
+++ b/meta-python/recipes-devtools/python/python3-multidict_2.1.4.bb
@@ -5,5 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
inherit pypi setuptools3
+SRC_URI += "file://0001-Allow-calling-make-clean-without-sphinx-build.patch"
+
SRC_URI[md5sum] = "051d92edec87fd98e43ea83f3ce6072d"
SRC_URI[sha256sum] = "a77aa8c9f68846c3b5db43ff8ed2a7a884dbe845d01f55113a3fba78518c4cd7"