aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Kling <andreas.kling@peiker-cee.de>2017-02-10 10:07:22 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-13 18:43:36 +0100
commitf93ea40311679d528cb20514a455347c75fd6046 (patch)
tree5cb5f676bccedfed8c5c131a7b6224c93955f901
parentf2b6681cb6fb6c4d14f32cf7a0c95671e8798a35 (diff)
downloadmeta-openembedded-contrib-f93ea40311679d528cb20514a455347c75fd6046.tar.gz
dconf: make gtk+3 dependency optional
dconf requires gtk+3 only for dconf-editor and is useful even on systems without gui. add PACKAGECONFIG for editor, enable it by default if x11 is present in DISTRO_FEATURES add x11 to REQUIRED_DISTRO_FEATURES only if editor is enabled Note: editor will be dropped from dconf in version 0.23.1 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-gnome/recipes-gnome/dconf/dconf_0.18.0.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/meta-gnome/recipes-gnome/dconf/dconf_0.18.0.bb b/meta-gnome/recipes-gnome/dconf/dconf_0.18.0.bb
index f7666cc0f2..e24bde4497 100644
--- a/meta-gnome/recipes-gnome/dconf/dconf_0.18.0.bb
+++ b/meta-gnome/recipes-gnome/dconf/dconf_0.18.0.bb
@@ -9,15 +9,20 @@ SRC_URI[archive.md5sum] = "69a12ed68893f2e1e81ac4e531bc1515"
SRC_URI[archive.sha256sum] = "109b1bc6078690af1ed88cb144ef5c5aee7304769d8bdc82ed48c3696f10c955"
GNOME_COMPRESS_TYPE = "xz"
-DEPENDS = "dbus glib-2.0 gtk+3 libxml2 intltool-native"
+DEPENDS = "dbus glib-2.0 libxml2 intltool-native"
inherit vala gtk-doc distro_features_check
-REQUIRED_DISTRO_FEATURES = "x11"
+PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "x11", "editor", "", d)}"
+
+#note: editor will be removed in version 0.23.1
+PACKAGECONFIG[editor] = "--enable-editor,--disable-editor,gtk+3"
+
+REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains("PACKAGECONFIG", "editor", "x11", "", d)}"
EXTRA_OECONF += "--disable-man"
-PACKAGES =+ "dconf-editor"
+PACKAGES =+ "${@bb.utils.contains("DISTRO_FEATURES", "x11", "dconf-editor", "", d)}"
FILES_${PN} += " \
${datadir}/dbus-1 \