aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartosz Golaszewski <bgolaszewski@baylibre.com>2019-09-23 12:00:57 +0200
committerKhem Raj <raj.khem@gmail.com>2019-09-23 08:33:10 -0700
commit5d70b390436a36475e84bf45ffbfa9b192c5d6f8 (patch)
treed4d9f54905f206f70aed3a8166164ede8397e602
parent190bd286f2a246da648949fa7b00e471bf9d81dd (diff)
downloadmeta-openembedded-contrib-5d70b390436a36475e84bf45ffbfa9b192c5d6f8.tar.gz
python3-ruamel-yaml: new package
Add a pypi recipe for ruamel-yaml parser. Based on the recipe found in meta-homeassistant by Oleksandr Andrushchenko. Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.5.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.5.bb b/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.5.bb
new file mode 100644
index 0000000000..ba095648fb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.5.bb
@@ -0,0 +1,16 @@
+SUMMARY = "YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order."
+AUTHOR = "Anthon van der Neut"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=caf8bd842440b537c044e131785a4666"
+
+PYPI_PACKAGE = "ruamel.yaml"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "7d5a5b0a7621a1247b081cc8e4978354"
+SRC_URI[sha256sum] = "412a6f5cfdc0525dee6a27c08f5415c7fd832a7afcb7a0ed7319628aed23d408"
+
+do_install_prepend() {
+ export RUAMEL_NO_PIP_INSTALL_CHECK=1
+}