aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-06-10 21:46:50 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-07-16 09:39:06 +0200
commit365d5ec941347f54744b9f5fbb7b06cc3949e14a (patch)
tree322e21d7d6a98669598f40d51f89e4d8e048c273
parenta55a93180733f769d676d9e66f74bf10d5da6ff0 (diff)
downloadmeta-openembedded-contrib-365d5ec941347f54744b9f5fbb7b06cc3949e14a.tar.gz
gateone: move systemd support to meta-systemd
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
-rw-r--r--meta-oe/recipes-connectivity/gateone/gateone_git.bb9
-rw-r--r--meta-systemd/meta-oe/recipes-connectivity/gateone/gateone/gateone.service (renamed from meta-oe/recipes-connectivity/gateone/gateone/gateone.service)0
-rw-r--r--meta-systemd/meta-oe/recipes-connectivity/gateone/gateone_git.bbappend11
3 files changed, 13 insertions, 7 deletions
diff --git a/meta-oe/recipes-connectivity/gateone/gateone_git.bb b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
index 12f4e5107a..f6aa3776d6 100644
--- a/meta-oe/recipes-connectivity/gateone/gateone_git.bb
+++ b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
@@ -2,19 +2,18 @@ DESCRIPTION = "HTML5 (plugin-free) web-based terminal emulator and SSH client"
LICENSE = "AGPLv3"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ee5b168fc7de89a0cadc49e27830aa2c"
-PR = "r7"
+PR = "r8"
PV = "1.1"
SRCREV = "bb74e1095adb66b04b51ed6ff10ae0aa96afdd46"
SRC_URI = "git://github.com/liftoff/GateOne.git \
file://gateone-avahi.service \
- file://gateone.service \
file://server.conf \
"
S = "${WORKDIR}/git"
-inherit distutils allarch systemd
+inherit distutils allarch
export prefix = "${localstatedir}/lib"
@@ -27,10 +26,6 @@ do_install_append() {
install -m 0644 ${WORKDIR}/server.conf ${D}/var/lib/gateone/server.conf
}
-NATIVE_SYSTEMD_SUPPORT = "1"
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE = "gateone.service"
-
FILES_${PN} = "${localstatedir}/lib ${localstatedir}/log ${base_libdir} ${sysconfdir}"
RDEPENDS_${PN} = "file \
mime-support \
diff --git a/meta-oe/recipes-connectivity/gateone/gateone/gateone.service b/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone/gateone.service
index 7ff60020a0..7ff60020a0 100644
--- a/meta-oe/recipes-connectivity/gateone/gateone/gateone.service
+++ b/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone/gateone.service
diff --git a/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone_git.bbappend b/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone_git.bbappend
new file mode 100644
index 0000000000..dd5fea1a96
--- /dev/null
+++ b/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone_git.bbappend
@@ -0,0 +1,11 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+PRINC := "${@int(PRINC) + 1}"
+
+inherit systemd
+
+SRC_URI += "file://gateone.service"
+
+NATIVE_SYSTEMD_SUPPORT = "1"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE = "gateone.service"