aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaciej Borzecki <maciej.borzecki@open-rnd.pl>2014-08-14 11:11:21 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-15 17:07:03 +0200
commit576206dd2f3b5d277702370db60b6b8aa50ff3b3 (patch)
treefac3ea930a5d9f421bc42330b939e5628578c0ec
parent1bb753b67ae8d90ce87b839c3b5b878066bb3bfe (diff)
downloadmeta-openembedded-contrib-576206dd2f3b5d277702370db60b6b8aa50ff3b3.tar.gz
rabbitmq-c: add recipe
rabbitmq-c is a C library providing an implementation of AMQP client for use with v2.0+ of the RabbitMQ broker Signed-off-by: Maciej Borzecki <maciej.borzecki@open-rnd.pl> Signed-off-by: Maciek Borzecki <maciek.borzecki@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/rabbitmq-c/rabbitmq-c_0.5.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/rabbitmq-c/rabbitmq-c_0.5.0.bb b/meta-oe/recipes-connectivity/rabbitmq-c/rabbitmq-c_0.5.0.bb
new file mode 100644
index 0000000000..91acb1d3c2
--- /dev/null
+++ b/meta-oe/recipes-connectivity/rabbitmq-c/rabbitmq-c_0.5.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "A C-language AMQP client library for use with v2.0+ of the RabbitMQ broker"
+HOMEPAGE = "https://github.com/alanxz/rabbitmq-c"
+LIC_FILES_CHKSUM = "file://LICENSE-MIT;md5=6b7424f9db80cfb11fdd5c980b583f53"
+LICENSE = "MIT"
+
+SRC_URI = "https://github.com/alanxz/${BPN}/releases/download/v${PV}/${BP}.tar.gz"
+SRC_URI[md5sum] = "b1f902c658c772cda464754678d8deb6"
+SRC_URI[sha256sum] = "53702ea2ab809af0f923e387458e2cad191d9549f50410035fe82ce5e6ccc4fa"
+
+DEPENDS = "popt openssl"
+
+EXTRA_OECONF = "--disable-examples --enable-tools --disable-docs"
+
+inherit autotools pkgconfig
+
+PACKAGE_BEFORE_PN += "${PN}-tools"
+FILES_${PN}-tools = "${bindir}"