aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 14:26:31 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:22:04 +0200
commit87259e3768de680a7cb39fc9e0959a4387fb57f2 (patch)
treee79752c46c5955fd8bab079a44af37cdf3add4c2
parentab198bbcfae9239c761e412e800d497bdd8bedf4 (diff)
downloadmeta-openembedded-contrib-87259e3768de680a7cb39fc9e0959a4387fb57f2.tar.gz
strongswan: move systemd support from meta-systemd back to meta-oe
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/strongswan/strongswan_5.0.0.bb13
-rw-r--r--meta-systemd/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bbappend10
2 files changed, 8 insertions, 15 deletions
diff --git a/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bb b/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bb
index efacc8ea4c..2713f5b18c 100644
--- a/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bb
+++ b/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bb
@@ -5,7 +5,7 @@ SECTION = "console/network"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "gmp openssl flex-native flex bison-native"
-PR = "r2"
+PR = "r5"
SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2"
SRC_URI[md5sum] = "c8b861305def7c0abae04f7bbefec212"
@@ -15,11 +15,9 @@ EXTRA_OECONF = "--disable-curl --disable-soup --disable-ldap \
--enable-gmp --disable-mysql --disable-sqlite \
--enable-openssl"
-SYSTEMD_UNITDIR ??= "no"
+EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}"
-EXTRA_OECONF += "--with-systemdsystemunitdir=${SYSTEMD_UNITDIR}"
-
-inherit autotools
+inherit autotools systemd
RRECOMMENDS_${PN} = "kernel-module-ipsec"
@@ -31,3 +29,8 @@ FILES_${PN}-dbg += "${libdir}/ipsec/.debug ${libdir}/ipsec/plugins/.debug ${libe
FILES_${PN}-plugins += "${libdir}/ipsec/plugins/*"
INSANE_SKIP_${PN}-plugins = "staticdev"
+
+RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "${PN}.service"
diff --git a/meta-systemd/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bbappend b/meta-systemd/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bbappend
deleted file mode 100644
index 0a474fe3f5..0000000000
--- a/meta-systemd/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bbappend
+++ /dev/null
@@ -1,10 +0,0 @@
-inherit systemd
-
-PRINC := "${@int(PRINC) + 2}"
-
-SYSTEMD_UNITDIR = "${systemd_unitdir}/system"
-
-RPROVIDES_${PN} += "${PN}-systemd"
-RREPLACES_${PN} += "${PN}-systemd"
-RCONFLICTS_${PN} += "${PN}-systemd"
-SYSTEMD_SERVICE_${PN} = "${PN}.service"