aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-05-23 14:03:07 +0100
committerRoss Burton <ross.burton@arm.com>2022-07-14 13:42:55 +0100
commit09711ef7ec56c2353495afdc5b754e560e7a7141 (patch)
tree707e3e0b5a296975274551495d7a950664f80f0a
parent097f27386a2afb41262f365f86cccced5e0547d7 (diff)
downloadmeta-openembedded-contrib-09711ef7ec56c2353495afdc5b754e560e7a7141.tar.gz
python3-pyrad: fix build system specification
The upstream pyproject.toml says it needs to be built with the Poetry frontend, but that's deprecated behaviour and it should use the Poetry Core API instead. Signed-off-by: Ross Burton <ross.burton@arm.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pyrad/use-poetry-core.patch26
-rw-r--r--meta-python/recipes-devtools/python/python3-pyrad_2.4.bb2
2 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyrad/use-poetry-core.patch b/meta-python/recipes-devtools/python/python3-pyrad/use-poetry-core.patch
new file mode 100644
index 0000000000..43a177da0a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyrad/use-poetry-core.patch
@@ -0,0 +1,26 @@
+Upstream-Status: Backport [https://github.com/pyradius/pyrad/commit/ffe182a44909e8f8278fb3e2ea052ddc097b48b9]
+Signed-off-by: Ross Burton <ross.burton@arm.com>
+
+From a4b70067dd6269e14a2f9530d820390a8a454231 Mon Sep 17 00:00:00 2001
+From: Martin Weinelt <hexa@darmstadt.ccc.de>
+Date: Thu, 14 Apr 2022 22:07:37 +0200
+Subject: [PATCH] Use poetry-core for pyproject based builds
+
+https://github.com/python-poetry/poetry-core#why-is-this-required
+---
+ pyproject.toml | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index 87b1df3..711c52f 100755
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -1,6 +1,6 @@
+ [build-system]
+-requires = ["poetry>=1.0"]
+-build-backend = "poetry.masonry.api"
++requires = ["poetry-core>=1.0.0"]
++build-backend = "poetry.core.masonry.api"
+
+ [tool.poetry]
+ name = "pyrad"
diff --git a/meta-python/recipes-devtools/python/python3-pyrad_2.4.bb b/meta-python/recipes-devtools/python/python3-pyrad_2.4.bb
index b2d0dc324b..bce1e2fd14 100644
--- a/meta-python/recipes-devtools/python/python3-pyrad_2.4.bb
+++ b/meta-python/recipes-devtools/python/python3-pyrad_2.4.bb
@@ -6,4 +6,6 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665
PYPI_PACKAGE = "pyrad"
SRC_URI[sha256sum] = "057de4b7e89d8da57ba782c1bde45c63ebee720ae2c0b0a69beaff15c47e30d9"
+SRC_URI += "file://use-poetry-core.patch"
+
inherit pypi python_poetry_core