aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2022-07-04 23:48:09 +0800
committerKhem Raj <raj.khem@gmail.com>2022-07-06 00:08:14 -0400
commite4e528dba2699842e695add07af9ff870fe4ed8b (patch)
tree8b7a9817d73f6d6e616d57137857b4762a8c185b
parentc68cead2917f03e871e744ce19d706b03e29cf63 (diff)
downloadmeta-openembedded-contrib-e4e528dba2699842e695add07af9ff870fe4ed8b.tar.gz
libdbi-perl: fix interpreter on shebang line
Update interpreter on shebang line in scripts to fix error: ERROR: QA Issue: : /work/x86_64-linux/libdbi-perl-native/1.643-r0/sysroot-destdir/work/x86_64-linux/libdbi-perl-native/1.643-r0/recipe-sysroot-native/usr/bin/dbiproxy maximum shebang size exceeded, the maximum size is 128. [shebang-size] ERROR: QA Issue: : /work/x86_64-linux/libdbi-perl-native/1.643-r0/sysroot-destdir/work/x86_64-linux/libdbi-perl-native/1.643-r0/recipe-sysroot-native/usr/bin/dbiprof maximum shebang size exceeded, the maximum size is 128. [shebang-size] ERROR: QA Issue: : /work/x86_64-linux/libdbi-perl-native/1.643-r0/sysroot-destdir/work/x86_64-linux/libdbi-perl-native/1.643-r0/recipe-sysroot-native/usr/bin/dbilogstrip maximum shebang size exceeded, the maximum size is 128. [shebang-size] Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/perl/libdbi-perl_1.643.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/perl/libdbi-perl_1.643.bb b/meta-oe/recipes-devtools/perl/libdbi-perl_1.643.bb
index 94f98fe40f..1fee83a8fd 100644
--- a/meta-oe/recipes-devtools/perl/libdbi-perl_1.643.bb
+++ b/meta-oe/recipes-devtools/perl/libdbi-perl_1.643.bb
@@ -29,6 +29,11 @@ do_install:prepend() {
rm -rf ${B}/t/z*.t
}
+do_install:append() {
+ sed -i "s:^#!.*:#!/usr/bin/env perl:" ${D}${bindir}/dbiproxy \
+ ${D}${bindir}/dbiprof ${D}${bindir}/dbilogstrip
+}
+
RDEPENDS:${PN}:class-target = " \
perl \
perl-module-carp \