aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-05-11 19:21:39 +0000
committerKhem Raj <raj.khem@gmail.com>2018-05-18 12:30:56 -0700
commit8d2d88f4275cddb0e1541c51c1eb5063ede2f38f (patch)
tree0c20dc8dde424c94e4393fb8245f00fc0a30b830
parent432b411d0758754a825c5234f5e989c1caa44e00 (diff)
downloadmeta-openembedded-contrib-8d2d88f4275cddb0e1541c51c1eb5063ede2f38f.tar.gz
spice: fix build with FORTIFY_SOURCES already defined in native gcc
* e.g. on gentoo hosts * use 4 spaces for indentation Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-support/spice/files/0001-spice-compile-warnings.m4-don-t-define-FORITFY_SOURC.patch37
-rw-r--r--meta-networking/recipes-support/spice/spice_git.bb32
2 files changed, 54 insertions, 15 deletions
diff --git a/meta-networking/recipes-support/spice/files/0001-spice-compile-warnings.m4-don-t-define-FORITFY_SOURC.patch b/meta-networking/recipes-support/spice/files/0001-spice-compile-warnings.m4-don-t-define-FORITFY_SOURC.patch
new file mode 100644
index 0000000000..666960566b
--- /dev/null
+++ b/meta-networking/recipes-support/spice/files/0001-spice-compile-warnings.m4-don-t-define-FORITFY_SOURC.patch
@@ -0,0 +1,37 @@
+From bf85d26f0326d4ea20429c29fd408703ee5bad54 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Wed, 13 Sep 2017 15:53:02 +0200
+Subject: [PATCH] spice-compile-warnings.m4: don't define FORITFY_SOURCES
+
+* otherwise fails when the native gcc already defines
+ FORTIFY_SOURCES (e.g. in gentoo).
+ | In file included from ../../git/server/inputs_channel.c:19:0:
+ | ../config.h:17:0: error: "_FORTIFY_SOURCE" redefined [-Werror]
+ | # define _FORTIFY_SOURCE 2
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ m4/spice-compile-warnings.m4 | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/m4/spice-compile-warnings.m4 b/m4/spice-compile-warnings.m4
+index 959971a2..55352ad6 100644
+--- a/m4/spice-compile-warnings.m4
++++ b/m4/spice-compile-warnings.m4
+@@ -109,13 +109,6 @@ AC_DEFUN([SPICE_COMPILE_WARNINGS],[
+ # This should be < 1024 really. pixman_utils is the blackspot
+ # preventing lower usage
+ gl_WARN_ADD([-Wframe-larger-than=20460])
+-
+- # Use improved glibc headers
+- AH_VERBATIM([FORTIFY_SOURCE],
+- [/* Enable compile-time and run-time bounds-checking, and some warnings. */
+-#if __OPTIMIZE__
+-# define _FORTIFY_SOURCE 2
+-#endif
+ ])
+
+ # Extra special flags
+--
+2.14.1
+
diff --git a/meta-networking/recipes-support/spice/spice_git.bb b/meta-networking/recipes-support/spice/spice_git.bb
index 2039841ddf..dfe4613641 100644
--- a/meta-networking/recipes-support/spice/spice_git.bb
+++ b/meta-networking/recipes-support/spice/spice_git.bb
@@ -25,19 +25,21 @@ SRCREV_spice-protocol = "784407f248e7f99d2bfcc9368f9acd1efb2b9617"
SRCREV_FORMAT = "spice_spice-common_spice-protocol"
-SRC_URI = "git://anongit.freedesktop.org/spice/spice;name=spice \
- git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/spice-common;name=spice-common \
- git://anongit.freedesktop.org/spice/spice-protocol;destsuffix=git/spice-common/spice-protocol;name=spice-protocol \
- "
+SRC_URI = " \
+ git://anongit.freedesktop.org/spice/spice;name=spice \
+ git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/spice-common;name=spice-common \
+ git://anongit.freedesktop.org/spice/spice-protocol;destsuffix=git/spice-common/spice-protocol;name=spice-protocol \
+"
SRC_URI += " \
- file://spice-fix-CVE-2013-4282.patch \
- file://configure.ac-add-subdir-objects-to-AM_INIT_AUTOMAKE.patch \
- file://build-allow-separated-src-and-build-dirs.patch \
- file://0001-red_parse_qxl-Fix-BITMAP_FMT_IS_RGB-defined-but-not-.patch \
- file://0001-Use-PRI-macros-in-printf-to-keep-compatibility-betwe.patch \
- file://Fix-build-issues-with-gcc-7.patch \
- "
+ file://spice-fix-CVE-2013-4282.patch \
+ file://configure.ac-add-subdir-objects-to-AM_INIT_AUTOMAKE.patch \
+ file://build-allow-separated-src-and-build-dirs.patch \
+ file://0001-red_parse_qxl-Fix-BITMAP_FMT_IS_RGB-defined-but-not-.patch \
+ file://0001-Use-PRI-macros-in-printf-to-keep-compatibility-betwe.patch \
+ file://Fix-build-issues-with-gcc-7.patch \
+ file://0001-spice-compile-warnings.m4-don-t-define-FORITFY_SOURC.patch \
+"
S = "${WORKDIR}/git"
@@ -66,13 +68,13 @@ FILES_${PN}-protocol += "${includedir}/spice-1"
FILES_${PN}-protocol += "${datadir}/pkgconfig"
do_configure_prepend() {
- mkdir -p ${S}/spice-common/spice-protocol/m4
+ mkdir -p ${S}/spice-common/spice-protocol/m4
}
do_install_append() {
- cd ${B}/spice-common/spice-protocol
- oe_runmake DESTDIR="${D}" install
- cd -
+ cd ${B}/spice-common/spice-protocol
+ oe_runmake DESTDIR="${D}" install
+ cd -
}
COMPATIBLE_HOST = '(x86_64|i.86).*-linux'