aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-02-01 14:23:40 +0000
committerArmin Kuster <akuster808@gmail.com>2018-02-11 12:01:54 -0800
commit69fdb96e9b41ac5211ed9b21d2249202fd0853a8 (patch)
treea01fe6880765cdb89a47acca5babf17294e0d92b
parentcf4161777141c20a811113a5ad3216248bfa6412 (diff)
downloadmeta-openembedded-contrib-69fdb96e9b41ac5211ed9b21d2249202fd0853a8.tar.gz
samba, openwsman, pam-ssh-agent-auth, sblim-sfcb, passwdqc, python-pam, smbnetfs: require pam in DISTRO_FEATURES
* there is explicit dependency on libpam without respecting pam in DISTRO_FEATURES so add the check to prevent people building it against broken libpam Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb4
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.7.0.bb7
-rw-r--r--meta-oe/recipes-extended/openwsman/openwsman_2.6.3.bb3
-rw-r--r--meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb3
-rw-r--r--meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb3
-rw-r--r--meta-oe/recipes-support/passwdqc/passwdqc_1.3.1.bb3
-rw-r--r--meta-python/recipes-devtools/python/python-pam_1.8.2.bb3
7 files changed, 23 insertions, 3 deletions
diff --git a/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb b/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb
index fefc045386..c72936c087 100644
--- a/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb
+++ b/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb
@@ -11,6 +11,10 @@ HOMEPAGE ="http://sourceforge.net/projects/smbnetfs"
DEPENDS = "fuse samba"
DEPENDS_append_libc-musl = " libexecinfo"
+# samba depends on libpam
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "pam"
+
inherit autotools gitpkgv pkgconfig
PKGV = "${GITPKGVTAG}"
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.7.0.bb b/meta-networking/recipes-connectivity/samba/samba_4.7.0.bb
index 08c5882ddf..27918d2a0e 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.7.0.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.7.0.bb
@@ -40,9 +40,10 @@ inherit systemd waf-samba cpan-base perlnative update-rc.d
# remove default added RDEPENDS on perl
RDEPENDS_${PN}_remove = "perl"
-#DEPENDS += "readline virtual/libiconv zlib popt libtalloc libtdb libtevent libldb libbsd libaio libpam"
-DEPENDS += "readline virtual/libiconv zlib popt libtalloc libtdb libtevent libbsd libaio libpam"
-DEPENDS += "libldb"
+DEPENDS += "readline virtual/libiconv zlib popt libtalloc libtdb libtevent libldb libbsd libaio libpam"
+
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "pam"
DEPENDS_append_libc-musl = " libtirpc"
CFLAGS_append_libc-musl = " -I${STAGING_INCDIR}/tirpc"
diff --git a/meta-oe/recipes-extended/openwsman/openwsman_2.6.3.bb b/meta-oe/recipes-extended/openwsman/openwsman_2.6.3.bb
index c4778ca38a..f618f02b5d 100644
--- a/meta-oe/recipes-extended/openwsman/openwsman_2.6.3.bb
+++ b/meta-oe/recipes-extended/openwsman/openwsman_2.6.3.bb
@@ -12,6 +12,9 @@ SECTION = "Applications/System"
DEPENDS = "curl libxml2 openssl libpam"
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "pam"
+
SRCREV = "feb7ec9b004fcaea0dbe65ce8a1a79cc29dd994c"
PV = "2.6.3"
diff --git a/meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb b/meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb
index ff88533ff0..1638c41c88 100644
--- a/meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb
+++ b/meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb
@@ -13,6 +13,9 @@ SRC_URI[sha256sum] = "3c53d358d6eaed1b211239df017c27c6f9970995d14102ae67bae16d4f
DEPENDS += "libpam openssl"
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "pam"
+
# This gets us ssh-agent, which we are almost certain to want.
#
RDEPENDS_${PN} += "openssh-misc"
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
index c6b9f1019b..152ae22902 100644
--- a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
+++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
@@ -11,6 +11,9 @@ LICENSE = "EPL-1.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=f300afd598546add034364cd0a533261"
DEPENDS = "curl libpam openssl sblim-sfc-common unzip-native"
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "pam"
+
SRC_URI = "http://downloads.sourceforge.net/sblim/${BP}.tar.bz2 \
file://sfcb.service \
file://sblim-sfcb-1.3.9-sfcbrepos-schema-location.patch \
diff --git a/meta-oe/recipes-support/passwdqc/passwdqc_1.3.1.bb b/meta-oe/recipes-support/passwdqc/passwdqc_1.3.1.bb
index 198db3ce72..8fc0b35912 100644
--- a/meta-oe/recipes-support/passwdqc/passwdqc_1.3.1.bb
+++ b/meta-oe/recipes-support/passwdqc/passwdqc_1.3.1.bb
@@ -21,6 +21,9 @@ SECTION = "System Environment/Base"
DEPENDS += "libpam"
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "pam"
+
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://LICENSE;md5=1b4af6f3d4ee079a38107366e93b334d"
diff --git a/meta-python/recipes-devtools/python/python-pam_1.8.2.bb b/meta-python/recipes-devtools/python/python-pam_1.8.2.bb
index 05bddd527b..60a3b43de5 100644
--- a/meta-python/recipes-devtools/python/python-pam_1.8.2.bb
+++ b/meta-python/recipes-devtools/python/python-pam_1.8.2.bb
@@ -10,3 +10,6 @@ PYPI_PACKAGE = "python-pam"
inherit pypi setuptools
RDEPENDS_${PN} = "libpam"
+
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "pam"