aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-11-05 22:42:14 -0700
committerArmin Kuster <akuster808@gmail.com>2016-11-29 08:22:21 -0800
commit02bca9e5f4e7d11c3567b08d2817ceebd06ca62b (patch)
tree0fb90391cb67fcc4404cdfbec133944354fa6523
parent45c2854b04c4671f69334116a4452b5d5311b9dc (diff)
downloadmeta-openembedded-contrib-02bca9e5f4e7d11c3567b08d2817ceebd06ca62b.tar.gz
libplist: Remove rpaths surgically
Check for files first before operating on it Fixes QA errors like below /usr/lib/python2.7/site-packages/plist/__init__.py /usr/lib/python2.7/site-packages/plist/_plist.so /usr/lib/python2.7/site-packages/plist/plist.py Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. libplist: 3 installed and not shipped files. [installed-vs-shipped] Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit ecdf2c30801a7162952f20d96943a14db78d52c8) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/libimobiledevice/libplist_1.8.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/libimobiledevice/libplist_1.8.bb b/meta-oe/recipes-extended/libimobiledevice/libplist_1.8.bb
index 10d40fbafb..f78979619f 100644
--- a/meta-oe/recipes-extended/libimobiledevice/libplist_1.8.bb
+++ b/meta-oe/recipes-extended/libimobiledevice/libplist_1.8.bb
@@ -16,8 +16,16 @@ SRC_URI = "http://www.libimobiledevice.org/downloads/libplist-${PV}.tar.bz2 \
SRC_URI[md5sum] = "2a9e0258847d50f9760dc3ece25f4dc6"
SRC_URI[sha256sum] = "a418da3880308199b74766deef2a760a9b169b81a868a6a9032f7614e20500ec"
-PACKAGES =+ "${PN}-utils ${PN}++"
+do_install_append () {
+ if [ -e ${D}${libdir}/python*/site-packages/plist/_plist.so ]; then
+ chrpath -d ${D}${libdir}/python*/site-packages/plist/_plist.so
+ fi
+}
+
+PACKAGES =+ "${PN}-utils ${PN}++ ${PN}-python"
FILES_${PN} = "${libdir}/libplist${SOLIBS}"
FILES_${PN}++ = "${libdir}/libplist++${SOLIBS}"
FILES_${PN}-utils = "${bindir}/*"
+FILES_${PN}-python = "${libdir}/python*/site-packages/*"
+