aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-05-29 22:28:59 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2011-05-30 11:28:58 +0200
commit2ee9b627b8c093cf263fb2915384dde2b15409ad (patch)
tree1bae74ad186e9f7786570fbe8a2690a10ef8ed7c
parentaf738233bbae8ece8e3cde040eca2243e4821699 (diff)
downloadmeta-openembedded-contrib-2ee9b627b8c093cf263fb2915384dde2b15409ad.tar.gz
serial-utils: import from OE rev d4f0211e2078d5033ae0dee74664de5520d8392d
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/serial-utils/pty-forward-native.bb21
-rw-r--r--meta-oe/recipes-support/serial-utils/serial-forward_git.bb13
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/serial-utils/pty-forward-native.bb b/meta-oe/recipes-support/serial-utils/pty-forward-native.bb
new file mode 100644
index 0000000000..72dfa2220d
--- /dev/null
+++ b/meta-oe/recipes-support/serial-utils/pty-forward-native.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Receive a forwarded serial from serial-forward and provide a PTY"
+AUTHOR = "Holger 'Zecke' Freyther"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=ebb5c50ab7cab4baeffba14977030c07"
+SECTION = "console/network"
+SRCREV = "00dbec2636ae0385ad028587e20e446272ff97ec"
+PV = "1.1+gitr${SRCPV}"
+PR = "r0"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia.git;protocol=git"
+S = "${WORKDIR}/git/tools/serial_forward"
+
+inherit autotools native
+
+do_deploy[sstate-outputdirs] = "${DEPLOY_DIR_IMAGE}"
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0755 ${S}/src/pty_forward ${DEPLOY_DIR_IMAGE}/pty-forward
+}
+
+addtask deploy before do_package after do_install
diff --git a/meta-oe/recipes-support/serial-utils/serial-forward_git.bb b/meta-oe/recipes-support/serial-utils/serial-forward_git.bb
new file mode 100644
index 0000000000..0e4ec44dbb
--- /dev/null
+++ b/meta-oe/recipes-support/serial-utils/serial-forward_git.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Forward a serial using TCP/IP"
+AUTHOR = "Holger 'Zecke' Freyther'"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=ebb5c50ab7cab4baeffba14977030c07"
+SECTION = "console/devel"
+SRCREV = "00dbec2636ae0385ad028587e20e446272ff97ec"
+PV = "1.1+gitr${SRCPV}"
+PR = "r0"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia.git/;protocol=git"
+S = "${WORKDIR}/git/tools/serial_forward"
+
+inherit autotools