aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2014-02-26 22:49:57 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2014-02-28 23:36:59 +0000
commit56dde5189f20d3507cad39814b833be7626067a4 (patch)
treea7de5a643e7f33314ec7fbdaf783dd53ba818d69
parent8089aa451827cb791c7d795b9899dc152d1ceb66 (diff)
downloadmeta-openembedded-contrib-56dde5189f20d3507cad39814b833be7626067a4.tar.gz
klcc-cross: force rebuild for each MACHINE of the same arch
In case of subsequent builds for machines belonging to the same arch we have to rebuild the klcc-cross wrapper because it is harcoding the path to the headers in machine sysroot. This hack is necessary to avoid to mark the klibc infrastructure as machine-specific. Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
-rw-r--r--meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.3.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.3.bb b/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.3.bb
index 40a65fd562..068b3d54f7 100644
--- a/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.3.bb
+++ b/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.3.bb
@@ -28,3 +28,9 @@ do_package_write_ipk[noexec] = "1"
do_package_write_rpm[noexec] = "1"
do_package_write_deb[noexec] = "1"
do_package_write_tar[noexec] = "1"
+
+# The linux-libc-headers and klibc custom headers are not machine-specific
+# but are installed into machine sysroot.
+# Klcc wrapper is hardcoding som eof these paths thus, to keep te recipe
+# arch-specific, we force the rebuild of klcc-cross for each machine.
+do_compile[vardeps] += "MACHINE"