aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2014-07-05 17:30:37 -0700
committerTim Orling <TicoTimo@gmail.com>2014-08-24 19:47:44 -0700
commit04d91bb62294ba1bd3ebff2e5db86f21f9565864 (patch)
tree0bcb0fac4187a72aa4c422f1c43a9e159f23f5a1
parentf98d1474b378b8919a9936ed4a2a8b5040575fba (diff)
downloadmeta-openembedded-contrib-04d91bb62294ba1bd3ebff2e5db86f21f9565864.tar.gz
meta-maker: create layer
Signed-off-by: Tim Orling <TicoTimo@gmail.com>
-rw-r--r--meta-maker/COPYING.MIT17
-rw-r--r--meta-maker/README50
-rw-r--r--meta-maker/conf/layer.conf10
3 files changed, 77 insertions, 0 deletions
diff --git a/meta-maker/COPYING.MIT b/meta-maker/COPYING.MIT
new file mode 100644
index 0000000000..fb950dc69f
--- /dev/null
+++ b/meta-maker/COPYING.MIT
@@ -0,0 +1,17 @@
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/meta-maker/README b/meta-maker/README
new file mode 100644
index 0000000000..39db758924
--- /dev/null
+++ b/meta-maker/README
@@ -0,0 +1,50 @@
+meta-maker
+================================
+
+Introduction
+-------------------------
+
+This layer is intended to be the home of applications and tools for Makers
+in OpenEmbedded. While initial focus is on 3D printing, this is by no means
+intended to be an exclusive layer. Other applications for CNC machining,
+lasercutting, knitting, etc. are expected to follow and are welcome.
+
+Dependencies
+-------------------------
+
+The meta-maker layer depends on:
+
+ URI: git://git.openembedded.org/openembedded-core
+ layers: meta
+ branch: master
+ revision: HEAD
+
+ URI: git://git.openembedded.org/meta-openembedded
+ layers: meta-oe
+ branch: master
+ revision: HEAD
+
+Please follow the recommended setup procedures of your OE distribution.
+For Angstrom that is:
+ http://www.angstrom-distribution.org/building-angstrom,
+other distros should have similar online resources.
+
+Contributing
+-------------------------
+
+The meta-openembedded mailinglist
+(openembedded-devel@lists.openembedded.org) is used for questions,
+comments and patch review. It is subscriber only, so please register
+before posting.
+
+Send pull requests to openembedded-devel@lists.openembedded.org with
+'[meta-maker]' in the subject.
+
+When sending single patches, please use something like:
+'git send-email -M -1 --to=openembedded-devel@lists.openembedded.org --subject-prefix=meta-maker][PATCH'
+
+Maintenance
+-------------------------
+
+Maintainers:
+ Tim "moto-timo" Orling <TicoTimo@gmail.com>
diff --git a/meta-maker/conf/layer.conf b/meta-maker/conf/layer.conf
new file mode 100644
index 0000000000..f30a92caee
--- /dev/null
+++ b/meta-maker/conf/layer.conf
@@ -0,0 +1,10 @@
+# We might have a conf and classes directory, append to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "meta-maker"
+BBFILE_PATTERN_meta-maker := "^${LAYERDIR}/"
+BBFILE_PRIORITY_meta-maker = "7"
+