aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@intel.com>2021-08-25 01:53:09 +0000
committerTim Orling <timothy.t.orling@intel.com>2021-08-25 02:08:58 +0000
commit56cab32c19d511b630eb46be5ae3aba5d777e38a (patch)
tree4130a3ef019668535e6b8270990da57960da8a10
parent88c67feaf1c3635ad954fcb55289c74227aee3bb (diff)
downloadmeta-openembedded-contrib-timo/django-2.x-upstream-check.tar.gz
python3-django_2.2.x: only check upstream 2.2.xtimo/django-2.x-upstream-check
AUH currently sees this recipe needing to upgrade to 3.x but we do not want that. We are intentionally pinning at the 2.2.x LTS for this recipe. References: https://www.djangoproject.com/download/ Signed-off-by: Tim Orling <timothy.t.orling@intel.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-django_2.2.24.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-django_2.2.24.bb b/meta-python/recipes-devtools/python/python3-django_2.2.24.bb
index 2c0bcf720e..982362bdd1 100644
--- a/meta-python/recipes-devtools/python/python3-django_2.2.24.bb
+++ b/meta-python/recipes-devtools/python/python3-django_2.2.24.bb
@@ -1,4 +1,8 @@
require python-django.inc
+
+# Pin to 2.2.x LTS releases ONLY for this recipe
+UPSTREAM_CHECK_REGEX = "/${PYPI_PACKAGE}/(?P<pver>(2\.2\.\d*)+)/"
+
inherit setuptools3
SRC_URI[md5sum] = "ebf3bbb7716a7b11029e860475b9a122"