aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2020-04-12 21:33:30 +0200
committerKhem Raj <raj.khem@gmail.com>2020-04-12 22:57:22 -0700
commit781d7130dfba938df0fd96f9ddc72a33b0562a1f (patch)
treefe7a6f6f161c119e89fcdeef994679aa7ef752ab
parent42ebcbe87abac576176862821f00a54ae3e0b2f5 (diff)
downloadmeta-openembedded-contrib-781d7130dfba938df0fd96f9ddc72a33b0562a1f.tar.gz
poppler: Add splash PACKAGECONFIG and enable it by default
Splash graphics option is enabled by default in CMakeLists.txt. So * add it to our defaults to keep situation as it was before * when using splash follow upstream's suggestion and add boost to depends: | Warning: Use of boost is recommended for better performance. Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/poppler/poppler_0.86.1.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler_0.86.1.bb b/meta-oe/recipes-support/poppler/poppler_0.86.1.bb
index 073edef86e..a6067e634b 100644
--- a/meta-oe/recipes-support/poppler/poppler_0.86.1.bb
+++ b/meta-oe/recipes-support/poppler/poppler_0.86.1.bb
@@ -14,7 +14,7 @@ DEPENDS = "fontconfig zlib cairo lcms glib-2.0"
inherit cmake pkgconfig gobject-introspection
-PACKAGECONFIG ??= "jpeg openjpeg png tiff nss"
+PACKAGECONFIG ??= "jpeg openjpeg png tiff nss splash"
PACKAGECONFIG[jpeg] = "-DWITH_JPEG=ON -DENABLE_DCTDECODER=libjpeg,-DWITH_JPEG=OFF -DENABLE_DCTDECODER=none,jpeg"
PACKAGECONFIG[png] = "-DWITH_PNG=ON,-DWITH_PNG=OFF,libpng"
PACKAGECONFIG[tiff] = "-DWITH_TIFF=ON,-DWITH_TIFF=OFF,tiff"
@@ -22,6 +22,7 @@ PACKAGECONFIG[curl] = "-DENABLE_LIBCURL=ON,-DENABLE_LIBCURL=OFF,curl"
PACKAGECONFIG[openjpeg] = "-DENABLE_LIBOPENJPEG=openjpeg2,-DENABLE_LIBOPENJPEG=none,openjpeg"
PACKAGECONFIG[qt5] = "-DENABLE_QT5=ON,-DENABLE_QT5=OFF,qtbase qttools-native"
PACKAGECONFIG[nss] = "-DWITH_NSS3=ON,-DWITH_NSS3=OFF,nss"
+PACKAGECONFIG[splash] = "-DENABLE_SPLASH=ON,-DENABLE_SPLASH=OFF,boost"
# surprise - did not expect this to work :)
inherit ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'cmake_qt5', '', d)}