aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2014-07-12 07:53:49 -0700
committerTim Orling <TicoTimo@gmail.com>2014-08-24 19:45:17 -0700
commit552737a0a2aa8d3715108fc8411176d8b365b770 (patch)
tree9f00d564684082f9fe3c1d506c402c1a81839282
parent68a10e62d6a2ca23bd3d160f1f45a83ec22ef37d (diff)
downloadmeta-openembedded-contrib-552737a0a2aa8d3715108fc8411176d8b365b770.tar.gz
libxml-sax-base: add 1.08
Signed-off-by: Tim Orling <TicoTimo@gmail.com>
-rw-r--r--meta-perl/recipes-perl/libxml/libxml-sax-base-perl_1.08.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libxml/libxml-sax-base-perl_1.08.bb b/meta-perl/recipes-perl/libxml/libxml-sax-base-perl_1.08.bb
new file mode 100644
index 0000000000..b03ecd9de2
--- /dev/null
+++ b/meta-perl/recipes-perl/libxml/libxml-sax-base-perl_1.08.bb
@@ -0,0 +1,29 @@
+SUMMARY = "XML::SAX::Base- Base class SAX Drivers and Filters"
+DESCRIPTION = "This module has a very simple task - to be a base class \
+for PerlSAX drivers and filters. It's default behaviour is to pass the \
+input directly to the output unchanged. It can be useful to use this \
+module as a base class so you don't have to, for example, implement the \
+characters() callback.\
+\
+The main advantages that it provides are easy dispatching of events the \
+right way (ie it takes care for you of checking that the handler has \
+implemented that method, or has defined an AUTOLOAD), and the guarantee \
+that filters will pass along events that they aren't implementing to \
+handlers downstream that might nevertheless be interested in them."
+
+SECTION = "libs"
+
+HOMEPAGE = "http://metapan.org/pod/XML-SAX-Base/"
+
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://dist.ini;md5=bf28ad127cb82ea88636e2bcfcbb2883"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/G/GR/GRANTM/XML-SAX-Base-${PV}.tar.gz"
+SRC_URI[md5sum] = "38c8c3247dfd080712596118d70dbe32"
+SRC_URI[sha256sum] = "666270318b15f88b8427e585198abbc19bc2e6ccb36dc4c0a4f2d9807330219e"
+
+S = "${WORKDIR}/XML-SAX-Base-${PV}"
+
+inherit cpan
+
+BBCLASSEXTEND = "native"