aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2015-06-19 09:44:42 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2015-07-06 15:27:52 -0400
commit8621b51850332e5a7f3a05431e1f1c2aab6d6787 (patch)
tree79c42574d71f5dcf5caeaa9b7bf37c701879fcf6
parent51e4d5dc4a905082526717ebe138f43731d93d53 (diff)
downloadmeta-openembedded-contrib-8621b51850332e5a7f3a05431e1f1c2aab6d6787.tar.gz
drbd ufw linux-atm: correct certain packaging error
The named packages explicitly install some items under /lib, but the recipes assume they are in base_libdir. We change the recipes. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r--meta-networking/recipes-connectivity/ufw/ufw_0.33.bb4
-rw-r--r--meta-networking/recipes-support/drbd/drbd_8.4.4.bb6
-rw-r--r--meta-networking/recipes-support/linux-atm/linux-atm_2.5.2.bb5
3 files changed, 11 insertions, 4 deletions
diff --git a/meta-networking/recipes-connectivity/ufw/ufw_0.33.bb b/meta-networking/recipes-connectivity/ufw/ufw_0.33.bb
index 2721f8fa73..66e917e315 100644
--- a/meta-networking/recipes-connectivity/ufw/ufw_0.33.bb
+++ b/meta-networking/recipes-connectivity/ufw/ufw_0.33.bb
@@ -32,10 +32,12 @@ RRECOMMENDS_${PN} = " \
kernel-module-ipv6 \
"
+# Certain items are explicitly put under /lib, not base_libdir when installed.
+#
FILES_${PN} += " \
${sbindir}/* \
${datadir}/ufw/* \
- ${base_libdir}/ufw/* \
+ /lib/ufw/* \
${sysconfdir}/ufw/* \
${sysconfdir}/default/ufw \
"
diff --git a/meta-networking/recipes-support/drbd/drbd_8.4.4.bb b/meta-networking/recipes-support/drbd/drbd_8.4.4.bb
index 5baffc623d..7458707ada 100644
--- a/meta-networking/recipes-support/drbd/drbd_8.4.4.bb
+++ b/meta-networking/recipes-support/drbd/drbd_8.4.4.bb
@@ -46,6 +46,8 @@ do_install_append() {
RDEPENDS_${PN} += "bash perl"
+# The drbd items are explicitly put under /lib when installed.
+#
FILES_${PN} += "/run"
-FILES_${PN} += "${base_libdir}/drbd"
-FILES_${PN}-dbg += "${base_libdir}/drbd/.debug"
+FILES_${PN} += "/lib/drbd"
+FILES_${PN}-dbg += "/lib/drbd/.debug"
diff --git a/meta-networking/recipes-support/linux-atm/linux-atm_2.5.2.bb b/meta-networking/recipes-support/linux-atm/linux-atm_2.5.2.bb
index 0a9bd8c72b..d0c0cecc3c 100644
--- a/meta-networking/recipes-support/linux-atm/linux-atm_2.5.2.bb
+++ b/meta-networking/recipes-support/linux-atm/linux-atm_2.5.2.bb
@@ -19,4 +19,7 @@ file://COPYING.LGPL;md5=6e29c688d912da12b66b73e32b03d812"
inherit autotools pkgconfig
-FILES_${PN} += "${base_libdir}/firmware"
+# The firmware is explicitly put under /lib when installed.
+#
+
+FILES_${PN} += "/lib/firmware"