aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2015-06-11 16:56:14 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-06-17 22:36:12 +0200
commitc7ffe8da924e188d2bb199766b1cdeae0d904a19 (patch)
tree8b3279bf8d69f272c10be1e683e1122db8c6cb28
parentbc5c01d5a14c394e82c593eb274e18107d10b078 (diff)
downloadmeta-openembedded-contrib-c7ffe8da924e188d2bb199766b1cdeae0d904a19.tar.gz
xdotool: pass correct libdir to make
When MACHINE=qemux86-64 and enable multilib: ERROR: QA Issue: xdotool: Files/directories were installed but not shipped in any package: /usr/lib /usr/lib/libxdo.so /usr/lib/libxdo.so.1 /usr/lib/.debug /usr/lib/.debug/libxdo.so.1 Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. [installed-vs-shipped] Pass the correct libdir to make, otherwise it assumes $prefix/lib even on multilib. Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
-rw-r--r--meta-oe/recipes-graphics/xdotool/xdotool_1.20100416.2809.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/xdotool/xdotool_1.20100416.2809.bb b/meta-oe/recipes-graphics/xdotool/xdotool_1.20100416.2809.bb
index 43e6fda6a6..474d2986fd 100644
--- a/meta-oe/recipes-graphics/xdotool/xdotool_1.20100416.2809.bb
+++ b/meta-oe/recipes-graphics/xdotool/xdotool_1.20100416.2809.bb
@@ -15,7 +15,7 @@ SRC_URI = "http://semicomplete.googlecode.com/files/xdotool-${PV}.tar.gz"
SRC_URI[md5sum] = "1d5be641e512c343abfe5f78b39e6f19"
SRC_URI[sha256sum] = "42d7271fbc796e53db71bb221f311b9ff3c51d90a71c9487a9bd3101ca39894f"
-EXTRA_OEMAKE = "PREFIX=${prefix} INSTALLMAN=${mandir}"
+EXTRA_OEMAKE = "PREFIX=${prefix} INSTALLLIB=${libdir} INSTALLMAN=${mandir}"
do_install() {
oe_runmake -e install DESTDIR=${D} PREFIX=${prefix}