aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-07-04 17:19:31 -0700
committerKhem Raj <raj.khem@gmail.com>2021-07-06 10:25:27 -0700
commit819413a527ad18a519763be3854da39d234739c4 (patch)
tree944c0dc2a6d63c288f1224012ecb6b605b5078d5
parent51bb5a946d614de0bbb9bc8142c764bc26a14b92 (diff)
downloadmeta-openembedded-contrib-819413a527ad18a519763be3854da39d234739c4.tar.gz
portaudio-v19: Use GNUInstallDirs to make it portable
libdir varies for different architectures therefore do not hardcode it to lib Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/portaudio/portaudio-v19/0001-cmake-Use-GNUInstallDirs.patch49
-rw-r--r--meta-oe/recipes-support/portaudio/portaudio-v19_19.7.0.bb1
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/portaudio/portaudio-v19/0001-cmake-Use-GNUInstallDirs.patch b/meta-oe/recipes-support/portaudio/portaudio-v19/0001-cmake-Use-GNUInstallDirs.patch
new file mode 100644
index 0000000000..892399de70
--- /dev/null
+++ b/meta-oe/recipes-support/portaudio/portaudio-v19/0001-cmake-Use-GNUInstallDirs.patch
@@ -0,0 +1,49 @@
+From ced7af0420c1df0ac02f0c25e7c3534431ebd7fd Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 4 Jul 2021 17:09:49 -0700
+Subject: [PATCH] cmake: Use GNUInstallDirs
+
+Helps install cmakefiles in right libdir
+
+Upstream-Status: Submitted [https://github.com/PortAudio/portaudio/pull/610]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ CMakeLists.txt | 12 +++++++-----
+ 1 file changed, 7 insertions(+), 5 deletions(-)
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -6,6 +6,8 @@
+
+ CMAKE_MINIMUM_REQUIRED(VERSION 2.8)
+
++include(GNUInstallDirs)
++
+ # Check if the user is building PortAudio stand-alone or as part of a larger
+ # project. If this is part of a larger project (i.e. the CMakeLists.txt has
+ # been imported by some other CMakeLists.txt), we don't want to trump over
+@@ -452,18 +454,18 @@ IF(NOT PA_OUTPUT_OSX_FRAMEWORK AND NOT P
+ CONFIGURE_FILE(cmake_support/portaudio-2.0.pc.in ${CMAKE_CURRENT_BINARY_DIR}/portaudio-2.0.pc @ONLY)
+ INSTALL(FILES README.md DESTINATION share/doc/portaudio)
+ INSTALL(FILES LICENSE.txt DESTINATION share/doc/portaudio)
+- INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/portaudio-2.0.pc DESTINATION lib/pkgconfig)
++ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/portaudio-2.0.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+ INSTALL(FILES ${PA_PUBLIC_INCLUDES} DESTINATION include)
+ INSTALL(TARGETS ${PA_TARGETS}
+ EXPORT portaudio-targets
+- RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib)
+- INSTALL(EXPORT portaudio-targets FILE "portaudioTargets.cmake" DESTINATION "lib/cmake/portaudio")
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
++ INSTALL(EXPORT portaudio-targets FILE "portaudioTargets.cmake" DESTINATION "${CMAKE_INSTALL_LIBDIR}/cmake/portaudio")
+ EXPORT(TARGETS ${PA_TARGETS} FILE "${PROJECT_BINARY_DIR}/cmake/portaudio/portaudioTargets.cmake")
+ INSTALL(FILES "${CMAKE_BINARY_DIR}/cmake/portaudio/portaudioConfig.cmake"
+ "${CMAKE_BINARY_DIR}/cmake/portaudio/portaudioConfigVersion.cmake"
+- DESTINATION "lib/cmake/portaudio")
++ DESTINATION "${CMAKE_INSTALL_LIBDIR}/cmake/portaudio")
+
+ IF (NOT TARGET uninstall)
+ CONFIGURE_FILE(
diff --git a/meta-oe/recipes-support/portaudio/portaudio-v19_19.7.0.bb b/meta-oe/recipes-support/portaudio/portaudio-v19_19.7.0.bb
index 3a0f7894f1..aec482b9b7 100644
--- a/meta-oe/recipes-support/portaudio/portaudio-v19_19.7.0.bb
+++ b/meta-oe/recipes-support/portaudio/portaudio-v19_19.7.0.bb
@@ -8,6 +8,7 @@ PV = "v190700"
SRC_URI = " \
git://github.com/PortAudio/portaudio.git \
file://0001-Find-jack.patch \
+ file://0001-cmake-Use-GNUInstallDirs.patch \
"
SRCREV = "147dd722548358763a8b649b3e4b41dfffbcfbb6"
S = "${WORKDIR}/git"