aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnkit Navik <ankit.tarot@gmail.com>2019-05-29 14:18:06 +0530
committerKhem Raj <raj.khem@gmail.com>2019-05-29 02:21:42 -0700
commit7a81eea01aa06205732bddbe62df21f127c67955 (patch)
tree8804ba20579e44455d34b53ec4a4efe6ceadca73
parent8e641e28f630dac61a03373ad70c72a2370ad11e (diff)
downloadmeta-openembedded-contrib-7a81eea01aa06205732bddbe62df21f127c67955.tar.gz
safec: Initial recipe for safe C library
Add generic recipe for safe C library. This library implements the secure C11 Annex K functions on top of most libc implementations, which are missing from them. Signed-off-by: Ankit Navik <ankit.tarot@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-core/safec/safec_3.4.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/safec/safec_3.4.bb b/meta-oe/recipes-core/safec/safec_3.4.bb
new file mode 100644
index 0000000000..d55d081f34
--- /dev/null
+++ b/meta-oe/recipes-core/safec/safec_3.4.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Safe C Library"
+
+LICENSE = "safec"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6d0eb7dfc57806a006fcbc4e389cf164"
+SECTION = "lib"
+
+inherit autotools pkgconfig
+
+S = "${WORKDIR}/git"
+SRCREV = "62e6b2df55084316d027165d286e46beb40513dc"
+SRC_URI = "git://github.com/rurban/safeclib.git"
+
+COMPATIBLE_HOST = '(x86_64|i.86|powerpc|powerpc64|arm|aarch64).*-linux'
+
+RDEPENDS_${PN} = "perl"