aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2019-06-27 10:18:22 -0700
committerTim Orling <timothy.t.orling@linux.intel.com>2019-06-27 21:33:29 -0700
commita2710fa95701f2c5f105fd724648461eef3765e9 (patch)
tree966cd843bb0448ac7b9193ec9e1c850b58e07760
parent48ee67cedee4b74a8ee6086b6f38024745ff635d (diff)
downloadmeta-openembedded-contrib-a2710fa95701f2c5f105fd724648461eef3765e9.tar.gz
libtest-warn-perl: add recipe for 0.36
ptest dependency for libcgi-perl NAME Test::Warn - Perl extension to test methods for warnings DESCRIPTION A good style of Perl programming calls for a lot of diverse regression tests. This module provides a few convenience methods for testing warning based-code. If you are not already familiar with the Test::More manpage now would be the time to go take a look. Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
-rw-r--r--meta-perl/recipes-perl/libtest/libtest-warn-perl_0.36.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libtest/libtest-warn-perl_0.36.bb b/meta-perl/recipes-perl/libtest/libtest-warn-perl_0.36.bb
new file mode 100644
index 0000000000..c336da80f1
--- /dev/null
+++ b/meta-perl/recipes-perl/libtest/libtest-warn-perl_0.36.bb
@@ -0,0 +1,46 @@
+SUMMARY = "Test::Warn - Perl extension to test methods for warnings"
+DESCRIPTION = "This module provides a few convenience methods for testing \
+warning based code. \
+\
+If you are not already familiar with the Test::More manpage now would be \
+the time to go take a look. \
+"
+
+SECTION = "libs"
+HOMEPAGE= "https://metacpan.org/release/Test-Warn"
+
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://README;beginline=73;endline=78;md5=42b423d91c92ba59c215835a2ee9b57a"
+
+CPAN_PACKAGE = "Test-Warn"
+CPAN_AUTHOR = "BIGJ"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/B/BI/${CPAN_AUTHOR}/${CPAN_PACKAGE}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "3d958f43d36db263994affde5da09b51"
+SRC_URI[sha256sum] = "ecbca346d379cef8d3c0e4ac0c8eb3b2613d737ffaaeae52271c38d7bf3c6cda"
+
+S = "${WORKDIR}/${CPAN_PACKAGE}-${PV}"
+
+inherit cpan ptest-perl
+
+do_install_ptest() {
+ cp -r ${B}/blib ${D}${PTEST_PATH}
+ chown -R root:root ${D}${PTEST_PATH}
+}
+
+RDEPENDS_${PN} += " \
+ libsub-uplevel-perl \
+ perl-module-blib \
+ perl-module-carp \
+ perl-module-test-builder \
+ perl-module-test-builder-tester \
+ perl-module-test-tester \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ perl-module-file-spec \
+ perl-module-test-more \
+"
+
+BBCLASSEXTEND = "native nativesdk"