aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2015-04-15 08:27:12 -0700
committerTim Orling <TicoTimo@gmail.com>2015-04-16 07:58:19 -0700
commitfe13e2ccb414ea32085520e397fcc554b062afe4 (patch)
tree3d9910ccb327f2c0ae3a002a4df438d45e49ff8e
parent607e66c2d1063af1dd9dc7e5090c180a77266d6b (diff)
downloadmeta-openembedded-contrib-timo/python-cryptography.tar.gz
python-cryptography,-vectors: add 0.8.1timo/python-cryptography
python-cryptography is required by python-pyopenssl >= 0.14 Includes python-cryptography-vectors package for ptest Over 75k unit tests (100% coverage): * tested on nuc (x86) and beaglebone (arm) hardware. ** will overload ram on default qemux86/qemuarm Signed-off-by: Tim Orling <TicoTimo@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography-vectors_0.8.1.bb14
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography_0.8.1.bb46
3 files changed, 62 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-cryptography-vectors_0.8.1.bb b/meta-python/recipes-devtools/python/python-cryptography-vectors_0.8.1.bb
new file mode 100644
index 0000000000..a9b64ed137
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cryptography-vectors_0.8.1.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Test vectors for the cryptography package."
+SECTION = "devel/python"
+LICENSE = "Apache-2.0 | BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
+DEPENDS = "python-cryptography"
+SRCNAME = "cryptography_vectors"
+
+SRC_URI = "https://pypi.python.org/packages/source/c/cryptography-vectors/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+SRC_URI[md5sum] = "04fcfcc61aee62e3b4beb1740cd120ac"
+SRC_URI[sha256sum] = "4a69e66026bfce4b97f75e72fe262f5e8f71daddc081f6608e5b0db89e552504"
+
+inherit setuptools
diff --git a/meta-python/recipes-devtools/python/python-cryptography/run-ptest b/meta-python/recipes-devtools/python/python-cryptography/run-ptest
new file mode 100644
index 0000000000..0ba239c2a4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cryptography/run-ptest
@@ -0,0 +1,2 @@
+#!/bin/sh
+py.test
diff --git a/meta-python/recipes-devtools/python/python-cryptography_0.8.1.bb b/meta-python/recipes-devtools/python/python-cryptography_0.8.1.bb
new file mode 100644
index 0000000000..41e4acdb5b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cryptography_0.8.1.bb
@@ -0,0 +1,46 @@
+SUMMARY = "Provides cryptographic recipes and primitives to Python developers"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0 | BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
+DEPENDS += " python-cffi-native python-cffi python-enum34 python-six python-pyasn1"
+SRCNAME = "cryptography"
+
+SRC_URI = "https://pypi.python.org/packages/source/c/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+ file://run-ptest \
+"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+SRC_URI[md5sum] = "70dde78a5515abdbfd7a3d58f15689ab"
+SRC_URI[sha256sum] = "f4e041bc83c1be94d87116a7aa201c378b7c6581be4d83994b2da0a84499f73b"
+
+inherit pypi
+
+RDEPENDS_${PN} = "\
+ python-pyasn1\
+ python-six\
+ python-cffi\
+ python-enum34\
+ python-setuptools\
+ python-pycparser\
+ python-subprocess\
+ python-threading\
+ python-numbers\
+ python-contextlib\
+"
+
+RDEPENDS_${PN}-ptest = "\
+ ${PN}\
+ python-pytest\
+ python-pretend\
+ python-iso8601\
+ python-cryptography-vectors\
+"
+
+inherit ptest
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+ install -d ${D}${PTEST_PATH}/tests/hazmat
+ cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
+}