aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-10-17 13:22:00 -0700
committerTim Orling <timothy.t.orling@linux.intel.com>2017-10-22 01:24:42 -0700
commit3a23a7434be453459a0c99d4aee0c78f1a6f0bf5 (patch)
tree48422aae54b688741d4082185211087153fe3b68
parente2d19f695a28ff50885c40c3b1addc7a9e85766c (diff)
downloadmeta-openembedded-contrib-3a23a7434be453459a0c99d4aee0c78f1a6f0bf5.tar.gz
python*-cycler: add recipe for v0.10.0
Composable style cycles. Docs: http://matplotlib.org/cycler/ When plotting more than one line it is common to want to be able to cycle over one or more artist styles Dependency for python-matplotlib. Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
-rw-r--r--meta-python/recipes-devtools/python/python-cycler.inc12
-rw-r--r--meta-python/recipes-devtools/python/python-cycler_0.10.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-cycler_0.10.0.bb2
3 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-cycler.inc b/meta-python/recipes-devtools/python/python-cycler.inc
new file mode 100644
index 0000000000..e1fd7f7b8c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cycler.inc
@@ -0,0 +1,12 @@
+SUMMARY = "Composable style cycles"
+HOMEPAGE = "http://github.com/matplotlib/cycler"
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7713fe42cd766b15c710e19392bfa811"
+
+SRC_URI[md5sum] = "4cb42917ac5007d1cdff6cccfe2d016b"
+SRC_URI[sha256sum] = "cd7b2d1018258d7247a71425e9f26463dfb444d411c39569972f4ce586b0c9d8"
+
+inherit pypi
+
+RDEPENDS_${PN} += "${PYTHON_PN}-core ${PYTHON_PN}-lang ${PYTHON_PN}-six"
diff --git a/meta-python/recipes-devtools/python/python-cycler_0.10.0.bb b/meta-python/recipes-devtools/python/python-cycler_0.10.0.bb
new file mode 100644
index 0000000000..ef2ca4cb90
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cycler_0.10.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-cycler.inc
diff --git a/meta-python/recipes-devtools/python/python3-cycler_0.10.0.bb b/meta-python/recipes-devtools/python/python3-cycler_0.10.0.bb
new file mode 100644
index 0000000000..3a943c0f67
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cycler_0.10.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-cycler.inc