aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-10-28 10:20:43 +0200
committerKhem Raj <raj.khem@gmail.com>2021-11-01 05:45:17 -0700
commitdc01472dd9ec62112d971788ebcf58f32a681541 (patch)
tree4ea542cd0a00e0867cc4bce7a099391e5f53b5ee
parent8aac37b50236216fb4ac257028623ebb517787b9 (diff)
downloadmeta-openembedded-contrib-dc01472dd9ec62112d971788ebcf58f32a681541.tar.gz
nodejs: fix build without scrypt
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs/0001-crypto-fix-build-without-scrypt.patch38
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_16.11.1.bb1
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/0001-crypto-fix-build-without-scrypt.patch b/meta-oe/recipes-devtools/nodejs/nodejs/0001-crypto-fix-build-without-scrypt.patch
new file mode 100644
index 0000000000..3a2719af34
--- /dev/null
+++ b/meta-oe/recipes-devtools/nodejs/nodejs/0001-crypto-fix-build-without-scrypt.patch
@@ -0,0 +1,38 @@
+From 048203c97009c907ff3891f6ffa8f375fcf1045c Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Tue, 26 Oct 2021 08:34:39 -0700
+Subject: [PATCH] crypto: fix build without scrypt
+
+* add missing semicolon to fix:
+ In file included from ../src/node_crypto.h:47,
+ from ../src/node.cc:46:
+ ../src/crypto/crypto_scrypt.h:80:2:
+ error: expected ';' after struct definition
+ 80 | }
+ | ^
+ | ;
+
+ and fix typo in the comment
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+Upstream-Status: Submitted [https://github.com/nodejs/node/pull/40613]
+
+---
+ src/crypto/crypto_scrypt.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/crypto/crypto_scrypt.h b/src/crypto/crypto_scrypt.h
+index 4ca888e31d..3d185637f4 100644
+--- a/src/crypto/crypto_scrypt.h
++++ b/src/crypto/crypto_scrypt.h
+@@ -77,8 +77,8 @@ struct ScryptJob {
+ static void Initialize(
+ Environment* env,
+ v8::Local<v8::Object> target) {}
+-}
+-#endif // !OPENSSL_NO_SCRIPT
++};
++#endif // !OPENSSL_NO_SCRYPT
+
+ } // namespace crypto
+ } // namespace node
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_16.11.1.bb b/meta-oe/recipes-devtools/nodejs/nodejs_16.11.1.bb
index beed833c09..20e4c6614d 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_16.11.1.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_16.11.1.bb
@@ -24,6 +24,7 @@ SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz \
file://mips-less-memory.patch \
file://system-c-ares.patch \
file://0001-liftoff-Correct-function-signatures.patch \
+ file://0001-crypto-fix-build-without-scrypt.patch \
"
SRC_URI:append:class-target = " \
file://0002-Using-native-binaries.patch \