aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2021-08-23 16:31:42 -0700
committerTim Orling <ticotimo@gmail.com>2021-08-24 15:32:59 -0700
commit410db2030bb8eb892209b971fac1e60a655fc112 (patch)
treea29b42eae0a9d9da25d646f152a14308700d1a1f
parent88c67feaf1c3635ad954fcb55289c74227aee3bb (diff)
downloadmeta-openembedded-contrib-410db2030bb8eb892209b971fac1e60a655fc112.tar.gz
python3-setuptools-rust-native add 0.12.1
Dependency for python3-cryptography 3.4.7 Depends on meta-rust (until rust support lands in oe-core) Add to dynamic-layers/rust-layer. Only -native is supported at this time, no target rust compiler yet. Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--meta-python/conf/layer.conf5
-rw-r--r--meta-python/dynamic-layers/rust-layer/recipes-devtools/python/python3-setuptools-rust-native_0.12.1.bb24
2 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/conf/layer.conf b/meta-python/conf/layer.conf
index ffad953f93..aa985361f4 100644
--- a/meta-python/conf/layer.conf
+++ b/meta-python/conf/layer.conf
@@ -8,6 +8,11 @@ BBFILE_COLLECTIONS += "meta-python"
BBFILE_PATTERN_meta-python := "^${LAYERDIR}/"
BBFILE_PRIORITY_meta-python = "7"
+BBFILES_DYNAMIC += " \
+ meta-python:${LAYERDIR}/dynamic-layers/rust-layer/*/*/*.bb \
+ meta-python:${LAYERDIR}/dynamic-layers/rust-layer/*/*/*.bbappend \
+"
+
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_meta-python = "1"
diff --git a/meta-python/dynamic-layers/rust-layer/recipes-devtools/python/python3-setuptools-rust-native_0.12.1.bb b/meta-python/dynamic-layers/rust-layer/recipes-devtools/python/python3-setuptools-rust-native_0.12.1.bb
new file mode 100644
index 0000000000..23169d1a58
--- /dev/null
+++ b/meta-python/dynamic-layers/rust-layer/recipes-devtools/python/python3-setuptools-rust-native_0.12.1.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Setuptools Rust extension plugin"
+HOMEPAGE = "https://github.com/PyO3/setuptools-rust"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=011cd92e702dd9e6b1a26157b6fd53f5"
+
+SRC_URI[sha256sum] = "647009e924f0ae439c7f3e0141a184a69ad247ecb9044c511dabde232d3d570e"
+SRC_URI[sha384sum] = "2162e5e347ded97c849466da40fb17907648e848ee663c09caad316349caca9648dc73161d747ac91535a4120d8706b5"
+SRC_URI[sha512sum] = "02dc2e2c91533ae847cfe7be0e7b0816fb376405f979c9767ba415c0223aa57429f1c038eb6c06ac9ec3950738b55026fbc6d4c8a8d938cf58a975d40d84cdb8"
+
+inherit cargo pypi setuptools3 native
+
+DEPENDS += "python3-setuptools-scm-native python3-wheel-native"
+
+RDEPENDS:${PN}:class-native += " \
+ python3-semantic-version-native \
+ python3-setuptools-native \
+ python3-setuptools-scm-native \
+ python3-toml-native \
+ python3-wheel-native \
+ "
+
+# WARNING: We were unable to map the following python package/module
+# dependencies to the bitbake packages which include them:
+# fat_macho