aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-06-10 17:08:08 +0200
committerKhem Raj <raj.khem@gmail.com>2018-06-14 08:57:14 -0700
commit13f311d88ffda574f3c0e3b70b8fbe3907c5629f (patch)
tree4fddb80a644004e8e3739d09fa72105349851e4e
parent409780a7482c02553156fbae064990ef874044c6 (diff)
downloadmeta-openembedded-contrib-13f311d88ffda574f3c0e3b70b8fbe3907c5629f.tar.gz
xfce4-settings: fix build after update of xfconf
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
-rw-r--r--meta-xfce/recipes-xfce/xfce4-settings/files/0002-Fix-linking-to-dbus-glib-bug-13633.patch41
-rw-r--r--meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb1
2 files changed, 42 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-settings/files/0002-Fix-linking-to-dbus-glib-bug-13633.patch b/meta-xfce/recipes-xfce/xfce4-settings/files/0002-Fix-linking-to-dbus-glib-bug-13633.patch
new file mode 100644
index 0000000000..109b7b1459
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfce4-settings/files/0002-Fix-linking-to-dbus-glib-bug-13633.patch
@@ -0,0 +1,41 @@
+From b6e46e6a84e45f7bd954687be703987825a54c1e Mon Sep 17 00:00:00 2001
+From: Eric Koegel <eric.koegel@gmail.com>
+Date: Sun, 11 Jun 2017 11:38:26 +0300
+Subject: [PATCH] Fix linking to dbus-glib (bug #13633)
+
+With xfconf moving to GDBus nothing provides the libs for dbus-glib
+that xfce4-settings requires. This patch adds the libs back in until
+settings can be ported to GDBus.
+
+Signed-off-by: Sean Davis <smd.seandavis@gmail.com>
+
+Upstream-Status: Backport
+---
+ xfce4-settings-editor/Makefile.am | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/xfce4-settings-editor/Makefile.am b/xfce4-settings-editor/Makefile.am
+index 5964366..c2c7c4b 100644
+--- a/xfce4-settings-editor/Makefile.am
++++ b/xfce4-settings-editor/Makefile.am
+@@ -28,6 +28,7 @@ xfce4_settings_editor_CFLAGS = \
+ $(LIBXFCE4UTIL_CFLAGS) \
+ $(LIBXFCE4UI_CFLAGS) \
+ $(XFCONF_CFLAGS) \
++ $(DBUS_GLIB_CFLAGS) \
+ $(PLATFORM_CFLAGS)
+
+ xfce4_settings_editor_LDFLAGS = \
+@@ -39,7 +40,8 @@ xfce4_settings_editor_LDADD = \
+ $(DBUS_GLIB_LIBS) \
+ $(LIBXFCE4UTIL_LIBS) \
+ $(LIBXFCE4UI_LIBS) \
+- $(XFCONF_LIBS)
++ $(XFCONF_LIBS) \
++ $(DBUS_GLIB_LIBS)
+
+ desktopdir = $(datadir)/applications
+ desktop_in_files = xfce4-settings-editor.desktop.in
+--
+2.14.3
+
diff --git a/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb b/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb
index bf9bd3102e..d937653fa4 100644
--- a/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb
+++ b/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb
@@ -15,6 +15,7 @@ REQUIRED_DISTRO_FEATURES = "x11"
SRC_URI = " \
git://github.com/schnitzeltony/xfce4-settings.git;protocol=git;branch=for-oe-4.12.3 \
file://0001-xsettings.xml-Set-default-themes.patch \
+ file://0002-Fix-linking-to-dbus-glib-bug-13633.patch \
"
SRCREV = "b701ac8b66b83c17469dd5009da51eeb59eba442"
S = "${WORKDIR}/git"