aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-06-17 00:52:28 -0700
committerKhem Raj <raj.khem@gmail.com>2018-06-17 00:52:28 -0700
commit803a69aa677b5dd31f5e7939bffc6c326e9673df (patch)
tree3f06a5d210048e0983f95f6854284b3503552d47
parentad8129041e1fdd4b7fa6f854f12c25b4e924456c (diff)
downloadmeta-openembedded-contrib-803a69aa677b5dd31f5e7939bffc6c326e9673df.tar.gz
move cpprest to meta-oe
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/cpprest/cpprest-2.10.2/fix-cmake-install.patch59
-rw-r--r--meta-networking/recipes-support/cpprest/cpprest_2.10.2.bb17
2 files changed, 0 insertions, 76 deletions
diff --git a/meta-networking/recipes-support/cpprest/cpprest-2.10.2/fix-cmake-install.patch b/meta-networking/recipes-support/cpprest/cpprest-2.10.2/fix-cmake-install.patch
deleted file mode 100644
index 56fd704ad7..0000000000
--- a/meta-networking/recipes-support/cpprest/cpprest-2.10.2/fix-cmake-install.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-Description: install cmake files into /usr/lib/cmake/cpprestsdk
-Author: Gianfranco Costamagna <locutusofborg@debian.org>
-Upstream-Status: https://github.com/Microsoft/cpprestsdk/pull/737
-Forwarded: https://github.com/Microsoft/cpprestsdk/pull/737
-Last-Update: 2018-04-19
-
-Index: cpprest/CMakeLists.txt
-===================================================================
---- cpprest.orig/CMakeLists.txt
-+++ cpprest/CMakeLists.txt
-@@ -18,7 +18,6 @@
- set(WERROR ON CACHE BOOL "Treat Warnings as Errors.")
- set(CPPREST_EXCLUDE_WEBSOCKETS OFF CACHE BOOL "Exclude websockets functionality.")
- set(CPPREST_EXCLUDE_COMPRESSION OFF CACHE BOOL "Exclude compression functionality.")
--set(CPPREST_EXPORT_DIR lib/cpprestsdk CACHE STRING "Directory to install CMake config files.")
- set(CPPREST_INSTALL_HEADERS ON CACHE BOOL "Install header files.")
- set(CPPREST_INSTALL ON CACHE BOOL "Add install commands.")
-
-@@ -63,6 +62,9 @@
- include(cmake/cpprest_find_openssl.cmake)
- include(cmake/cpprest_find_websocketpp.cmake)
- include(CheckIncludeFiles)
-+if(UNIX)
-+include(GNUInstallDirs)
-+endif(UNIX)
-
- find_package(Threads REQUIRED)
- if(THREADS_HAVE_PTHREAD_ARG)
-Index: cpprest/src/CMakeLists.txt
-===================================================================
---- cpprest.orig/src/CMakeLists.txt
-+++ cpprest/src/CMakeLists.txt
-@@ -250,21 +250,21 @@
- install(
- TARGETS ${CPPREST_TARGETS}
- EXPORT cpprestsdk-targets
-- RUNTIME DESTINATION bin
-- LIBRARY DESTINATION lib
-- ARCHIVE DESTINATION lib
-+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
-+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
-+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
- )
-
- configure_file(../cmake/cpprestsdk-config.in.cmake "${CMAKE_CURRENT_BINARY_DIR}/cpprestsdk-config.cmake" @ONLY)
-
- install(
- FILES "${CMAKE_CURRENT_BINARY_DIR}/cpprestsdk-config.cmake"
-- DESTINATION ${CPPREST_EXPORT_DIR}
-+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake
- )
- install(
- EXPORT cpprestsdk-targets
- FILE cpprestsdk-targets.cmake
- NAMESPACE cpprestsdk::
-- DESTINATION ${CPPREST_EXPORT_DIR}
-+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake
- )
- endif()
diff --git a/meta-networking/recipes-support/cpprest/cpprest_2.10.2.bb b/meta-networking/recipes-support/cpprest/cpprest_2.10.2.bb
deleted file mode 100644
index 2ba6fc66cc..0000000000
--- a/meta-networking/recipes-support/cpprest/cpprest_2.10.2.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-SUMMARY = "Microsoft project for cloud-based client-server communication in native code using a modern asynchronous C++ API design."
-SECTION = "libs/network"
-HOMEPAGE = "https://github.com/Microsoft/cpprestsdk/"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${S}/../license.txt;md5=a2e15b954769218ff912468eecd6a02f"
-DEPENDS = "openssl websocketpp zlib boost"
-
-SRC_URI = "git://github.com/Microsoft/cpprestsdk.git;protocol=https;branch=master"
-
-SRC_URI += "file://fix-cmake-install.patch"
-
-# tag 2.10.2
-SRCREV= "fea848e2a77563cf2a6f28f8eab396fd6e787fbf"
-
-S = "${WORKDIR}/git/Release"
-
-inherit cmake